summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2006-01-13 16:47:11 +0000
committerBenjamin Smee <strerror@gentoo.org>2006-01-13 16:47:11 +0000
commite2f47b91857d692b9887671a7cd01cf61c339374 (patch)
tree1203e2335e3912a8eb4b1d7a4c98bb6fd8ac6f4e /net-nds/openldap/files
parentVersion bump (diff)
downloadgentoo-2-e2f47b91857d692b9887671a7cd01cf61c339374.tar.gz
gentoo-2-e2f47b91857d692b9887671a7cd01cf61c339374.tar.bz2
gentoo-2-e2f47b91857d692b9887671a7cd01cf61c339374.zip
new 2.1 version to fix bugs #77330 , #105065 , #105380 , #110412 , #114544 , #115741 , #115792 , #115872 - thanks to Markus Ullmann
(Portage version: 2.0.53)
Diffstat (limited to 'net-nds/openldap/files')
-rw-r--r--net-nds/openldap/files/digest-openldap-2.1.30-r71
-rw-r--r--net-nds/openldap/files/openldap-2.1.30-autoconf-archived-fix.patch67
-rw-r--r--net-nds/openldap/files/openldap-2.1.30-m4_underquoted.patch101
-rw-r--r--net-nds/openldap/files/openldap-2.1.30-tests.patch12
4 files changed, 181 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-2.1.30-r7 b/net-nds/openldap/files/digest-openldap-2.1.30-r7
new file mode 100644
index 000000000000..a6a4a08b05c0
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.1.30-r7
@@ -0,0 +1 @@
+MD5 e2ae8148c4bed07d7a70edd930bdc403 openldap-2.1.30.tgz 2044673
diff --git a/net-nds/openldap/files/openldap-2.1.30-autoconf-archived-fix.patch b/net-nds/openldap/files/openldap-2.1.30-autoconf-archived-fix.patch
new file mode 100644
index 000000000000..19a1f710eb17
--- /dev/null
+++ b/net-nds/openldap/files/openldap-2.1.30-autoconf-archived-fix.patch
@@ -0,0 +1,67 @@
+--- ./configure.in.orig 2005-12-18 15:52:54.000000000 +0100
++++ ./configure.in 2005-12-18 15:54:24.000000000 +0100
+@@ -683,8 +683,8 @@
+
+ dnl ----------------------------------------------------------------
+ dnl Checks for system services
+-AC_CYGWIN
+-AC_MINGW32
++dnl AC_CYGWIN
++dnl AC_MINGW32
+ AC_EXEEXT
+ AC_OBJEXT
+
+@@ -2308,7 +2308,7 @@
+ AC_TYPE_MODE_T
+ AC_TYPE_OFF_T
+ AC_TYPE_PID_T
+-AM_TYPE_PTRDIFF_T
++AC_CHECK_TYPES([ptrdiff_t])
+ AC_TYPE_SIGNAL
+ AC_TYPE_SIZE_T
+
+@@ -2337,7 +2337,7 @@
+ AC_C_BIGENDIAN
+ fi
+
+-AC_COMPILE_CHECK_SIZEOF(short)
++OL_AC_COMPILE_CHECK_SIZEOF(short)
+-AC_COMPILE_CHECK_SIZEOF(int)
++OL_AC_COMPILE_CHECK_SIZEOF(int)
+-AC_COMPILE_CHECK_SIZEOF(long)
++OL_AC_COMPILE_CHECK_SIZEOF(long)
+
+ if test "$ac_cv_sizeof_int" -lt 4 ; then
+ AC_MSG_WARN([OpenLDAP requires 'int' to be 32 bits or greater.])
+--- ./build/openldap.m4.orig 2005-12-19 01:20:14.000000000 +0100
++++ ./build/openldap.m4 2005-12-19 01:24:11.000000000 +0100
+@@ -1237,3 +1237,29 @@
+ [define if struct msghdr has msg_accrights])
+ fi
+ ])dnl
++
++AC_DEFUN([OL_AC_COMPILE_CHECK_SIZEOF],
++[changequote(<<, >>)dnl
++dnl The name to #define.
++define(<<AC_TYPE_NAME>>, translit(sizeof_$1, [a-z *], [A-Z_P]))dnl
++dnl The cache variable name.
++define(<<AC_CV_NAME>>, translit(ac_cv_sizeof_$1, [ *], [_p]))dnl
++changequote([, ])dnl
++AC_MSG_CHECKING(size of $1)
++AC_CACHE_VAL(AC_CV_NAME,
++[for ac_size in 4 8 1 2 16 $2 ; do # List sizes in rough order of prevalence.
++ AC_TRY_COMPILE([#include "confdefs.h"
++#include <sys/types.h>
++$2
++], [switch (0) case 0: case (sizeof ($1) == $ac_size):;], AC_CV_NAME=$ac_size)
++ if test x$AC_CV_NAME != x ; then break; fi
++done
++])
++if test x$AC_CV_NAME = x ; then
++ AC_MSG_ERROR([cannot determine a size for $1])
++fi
++AC_MSG_RESULT($AC_CV_NAME)
++AC_DEFINE_UNQUOTED(AC_TYPE_NAME, $AC_CV_NAME, [The number of bytes in type $1])
++undefine([AC_TYPE_NAME])dnl
++undefine([AC_CV_NAME])dnl
++])
diff --git a/net-nds/openldap/files/openldap-2.1.30-m4_underquoted.patch b/net-nds/openldap/files/openldap-2.1.30-m4_underquoted.patch
new file mode 100644
index 000000000000..84bb7c014f08
--- /dev/null
+++ b/net-nds/openldap/files/openldap-2.1.30-m4_underquoted.patch
@@ -0,0 +1,101 @@
+--- openldap.m4.orig 2005-03-12 22:03:12.000000000 -0500
++++ openldap.m4 2005-12-06 17:09:19.000000000 -0500
+@@ -65,7 +65,7 @@
+ dnl
+ dnl ====================================================================
+ dnl
+-AC_DEFUN(AC_COMPILE_CHECK_SIZEOF,
++AC_DEFUN([AC_COMPILE_CHECK_SIZEOF],
+ [changequote(<<, >>)dnl
+ dnl The name to #define.
+ define(<<AC_TYPE_NAME>>, translit(sizeof_$1, [a-z *], [A-Z_P]))dnl
+@@ -173,7 +173,7 @@
+ dnl
+ dnl --------------------------------------------------------------------
+ dnl OpenLDAP version of STDC header check w/ EBCDIC support
+-AC_DEFUN(OL_HEADER_STDC,
++AC_DEFUN([OL_HEADER_STDC],
+ [AC_REQUIRE_CPP()dnl
+ AC_REQUIRE([OL_CPP_EBCDIC])dnl
+ AC_CACHE_CHECK([for ANSI C header files], ol_cv_header_stdc,
+@@ -1016,7 +1020,7 @@
+ dnl Early MIPS compilers (used in Ultrix 4.2) don't like
+ dnl "int x; int *volatile a = &x; *a = 0;"
+ dnl -- borrowed from PDKSH
+-AC_DEFUN(OL_C_VOLATILE,
++AC_DEFUN([OL_C_VOLATILE],
+ [AC_CACHE_CHECK(if compiler understands volatile, ol_cv_c_volatile,
+ [AC_TRY_COMPILE([int x, y, z;],
+ [volatile int a; int * volatile b = x ? &y : &z;
+@@ -1052,7 +1056,7 @@
+ dnl
+ dnl ====================================================================
+ dnl Define sig_atomic_t if not defined in signal.h
+-AC_DEFUN(OL_TYPE_SIG_ATOMIC_T,
++AC_DEFUN([OL_TYPE_SIG_ATOMIC_T],
+ [AC_CACHE_CHECK(for sig_atomic_t, ol_cv_type_sig_atomic_t,
+ [AC_TRY_COMPILE([#include <signal.h>], [sig_atomic_t atomic;],
+ ol_cv_type_sig_atomic_t=yes, ol_cv_type_sig_atomic_t=no)])
+@@ -1064,7 +1068,7 @@
+ dnl
+ dnl ====================================================================
+ dnl Define socklen_t if not defined in sys/types.h or sys/socket.h
+-AC_DEFUN(OL_TYPE_SOCKLEN_T,
++AC_DEFUN([OL_TYPE_SOCKLEN_T],
+ [AC_CACHE_CHECK(for socklen_t, ol_cv_type_socklen_t,
+ [AC_TRY_COMPILE([
+ #ifdef HAVE_SYS_TYPES_H
+@@ -1083,7 +1087,7 @@
+ dnl
+ dnl ====================================================================
+ dnl Define inet_aton is available
+-AC_DEFUN(OL_FUNC_INET_ATON,
++AC_DEFUN([OL_FUNC_INET_ATON],
+ [AC_CACHE_CHECK([for inet_aton()], ol_cv_func_inet_aton,
+ [AC_TRY_LINK([
+ #ifdef HAVE_SYS_TYPES_H
+@@ -1110,7 +1114,7 @@
+ dnl
+ dnl ====================================================================
+ dnl check no of arguments for ctime_r
+-AC_DEFUN(OL_FUNC_CTIME_R_NARGS,
++AC_DEFUN([OL_FUNC_CTIME_R_NARGS],
+ [AC_CACHE_CHECK(number of arguments of ctime_r, ol_cv_func_ctime_r_nargs,
+ [AC_TRY_COMPILE([#include <time.h>],
+ [time_t ti; char *buffer; ctime_r(&ti,buffer,32);],
+@@ -1145,7 +1149,7 @@
+ dnl
+ dnl --------------------------------------------------------------------
+ dnl check return type of ctime_r()
+-AC_DEFUN(OL_FUNC_CTIME_R_TYPE,
++AC_DEFUN([OL_FUNC_CTIME_R_TYPE],
+ [AC_CACHE_CHECK(return type of ctime_r, ol_cv_func_ctime_r_type,
+ [AC_TRY_COMPILE([#include <time.h>],
+ [extern int (ctime_r)();],
+@@ -1157,7 +1161,7 @@
+ ])dnl
+ dnl ====================================================================
+ dnl check no of arguments for gethostbyname_r
+-AC_DEFUN(OL_FUNC_GETHOSTBYNAME_R_NARGS,
++AC_DEFUN([OL_FUNC_GETHOSTBYNAME_R_NARGS],
+ [AC_CACHE_CHECK(number of arguments of gethostbyname_r,
+ ol_cv_func_gethostbyname_r_nargs,
+ [AC_TRY_COMPILE([#include <sys/types.h>
+@@ -1207,7 +1211,7 @@
+ ])dnl
+ dnl
+ dnl check no of arguments for gethostbyaddr_r
+-AC_DEFUN(OL_FUNC_GETHOSTBYADDR_R_NARGS,
++AC_DEFUN([OL_FUNC_GETHOSTBYADDR_R_NARGS],
+ [AC_CACHE_CHECK(number of arguments of gethostbyaddr_r,
+ [ol_cv_func_gethostbyaddr_r_nargs],
+ [AC_TRY_COMPILE([#include <sys/types.h>
+@@ -1283,7 +1287,7 @@
+ ])
+ dnl ====================================================================
+ dnl check for msg_accrights in msghdr
+-AC_DEFUN(OL_MSGHDR_MSG_ACCRIGHTS,
++AC_DEFUN([OL_MSGHDR_MSG_ACCRIGHTS],
+ [AC_CACHE_CHECK(for msg_accrights in msghdr, ol_cv_msghdr_msg_accrights,
+ [AC_TRY_COMPILE([#include <sys/socket.h>],
+ [struct msghdr m; m.msg_accrightslen=0],
diff --git a/net-nds/openldap/files/openldap-2.1.30-tests.patch b/net-nds/openldap/files/openldap-2.1.30-tests.patch
new file mode 100644
index 000000000000..5cde2ba073c4
--- /dev/null
+++ b/net-nds/openldap/files/openldap-2.1.30-tests.patch
@@ -0,0 +1,12 @@
+--- ./Makefile.in.orig 2003-03-03 18:10:11.000000000 +0100
++++ ./Makefile.in 2005-12-18 15:45:08.000000000 +0100
+@@ -8,6 +8,9 @@
+ BUILD_BDB=@BUILD_BDB@
+ BUILD_MONITOR=@BUILD_MONITOR@
+
++LD_LIBRARY_PATH=${pwd}../libraries/libldap_r/.libs:${pwd}../libraries/liblber/.libs:${pwd}../libraries/libldap/.libs:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH
++
+ test: tests
+ tests: bdb ldbm
+