summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-08-03 17:36:27 +0000
committerSebastian Pipping <sping@gentoo.org>2015-08-03 17:36:27 +0000
commitd7b5cfb13c3fc803d54793da4797810a850735cd (patch)
tree8ded2145ad9eab15933612a54a0212fd0cd3ad7b /net-nds
parentFix man page building and installation (bug #556344). (diff)
downloadgentoo-2-d7b5cfb13c3fc803d54793da4797810a850735cd.tar.gz
gentoo-2-d7b5cfb13c3fc803d54793da4797810a850735cd.tar.bz2
gentoo-2-d7b5cfb13c3fc803d54793da4797810a850735cd.zip
net-nds/smbldap-tools: Fix compilation (bug #505544)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/smbldap-tools/ChangeLog11
-rw-r--r--net-nds/smbldap-tools/files/smbldap-tools-0.9.10-smbldap-config-pod.patch37
-rw-r--r--net-nds/smbldap-tools/smbldap-tools-0.9.10-r1.ebuild57
3 files changed, 103 insertions, 2 deletions
diff --git a/net-nds/smbldap-tools/ChangeLog b/net-nds/smbldap-tools/ChangeLog
index 58ebcf288c66..4fbae5459b42 100644
--- a/net-nds/smbldap-tools/ChangeLog
+++ b/net-nds/smbldap-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nds/smbldap-tools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/smbldap-tools/ChangeLog,v 1.38 2013/08/11 02:22:21 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/smbldap-tools/ChangeLog,v 1.39 2015/08/03 17:36:27 sping Exp $
+
+*smbldap-tools-0.9.10-r1 (03 Aug 2015)
+
+ 03 Aug 2015; Sebastian Pipping <sping@gentoo.org>
+ +smbldap-tools-0.9.10-r1.ebuild,
+ +files/smbldap-tools-0.9.10-smbldap-config-pod.patch:
+ Apply patch from upstream bug #3013 to fix compilation (bug #505544)
*smbldap-tools-0.9.10 (11 Aug 2013)
diff --git a/net-nds/smbldap-tools/files/smbldap-tools-0.9.10-smbldap-config-pod.patch b/net-nds/smbldap-tools/files/smbldap-tools-0.9.10-smbldap-config-pod.patch
new file mode 100644
index 000000000000..127bc353f47d
--- /dev/null
+++ b/net-nds/smbldap-tools/files/smbldap-tools-0.9.10-smbldap-config-pod.patch
@@ -0,0 +1,37 @@
+From 4e3337697aa91f41ca970927233f96dbfa0b2d5d Mon Sep 17 00:00:00 2001
+From: Paul Howarth <paul@city-fan.org>
+Date: Mon, 3 Aug 2015 19:18:18 +0200
+Subject: [PATCH] Support podlators >=2.5.0
+
+http://gna.org/support/?3013
+---
+ smbldap-config.pl | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/smbldap-config.pl b/smbldap-config.pl
+index ecd9369..5660170 100644
+--- a/smbldap-config.pl
++++ b/smbldap-config.pl
+@@ -557,3 +557,19 @@ print " $smbldap_bind_conf done.\n";
+ $mode=0600;
+ chmod $mode,"$smbldap_bind_conf","$smbldap_bind_conf.old";
+
++__END__
++
++=head1 NAME
++
++smbldap-config - Configure the smbldap-tools
++
++=head1 SYNOPSIS
++
++smbldap-config
++
++=head1 DESCRIPTION
++
++An interactive script to configure the smbldap-tools to work with your
++existing LDAP server(s). Before running it, you should ensure that your
++samba controller is up and running, and that the domain SID is defined
++(you can check it by running 'net getlocalsid').
+--
+2.4.6
+
diff --git a/net-nds/smbldap-tools/smbldap-tools-0.9.10-r1.ebuild b/net-nds/smbldap-tools/smbldap-tools-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..74bf158d8d1e
--- /dev/null
+++ b/net-nds/smbldap-tools/smbldap-tools-0.9.10-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/smbldap-tools/smbldap-tools-0.9.10-r1.ebuild,v 1.1 2015/08/03 17:36:27 sping Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Samba LDAP management tools"
+HOMEPAGE="https://gna.org/projects/smbldap-tools/"
+SRC_URI="http://download.gna.org/smbldap-tools/sources/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/perl-ldap
+ dev-perl/Crypt-SmbHash
+ dev-perl/Digest-SHA1
+ dev-perl/Unicode-MapUTF8
+ dev-perl/IO-Socket-SSL
+ net-nds/openldap
+ net-fs/samba
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-smbldap-config-pod.patch
+}
+
+src_install() {
+ default
+
+ newsbin smbldap-config.cmd smbldap-config
+ dosym smbldap-passwd /usr/sbin/smbldap-passwd.cmd
+
+ dodoc CONTRIBUTORS ChangeLog FILES INFRA INSTALL README TODO doc/*conf* doc/smbldap-tools*
+ dodoc -r doc/migration_scripts
+
+ sed -i 's/.CMD//g' smbldap-[gpu]*.8 || die
+ doman smbldap-[gpu]*.8
+
+ insinto /etc/smbldap-tools
+ doins smbldap.conf smbldap_bind.conf
+
+ elog "Remember to read INSTALL when updating."
+}
+
+pkg_postinst() {
+ elog "- A good howto is found on http://download.gna.org/smbldap-tools/docs/samba-ldap-howto/"
+ elog " and http://download.gna.org/smbldap-tools/docs/smbldap-tools/"
+ elog "- The configure script is installed as smbldap-configure.pl. Please run it to configure the tools."
+ elog "- Examples configuration files for Samba and slapd have been copied to ${EPREFIX}/usr/share/doc/${PF},"
+ elog " together with the migration-scripts."
+ elog "- Also remember to read INSTALL when updating."
+}