summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-10 22:17:50 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-10 22:17:50 +0000
commit92fe83b83ad6e8a25eff32f91ff69a58fde31dbd (patch)
tree83aad39f6c92ebdb83d810cc8a15213bcd739900 /net-nntp/pan/pan-0.116.ebuild
parentBump to 0.1.7 (from 0.1.4). #150536 (diff)
downloadgentoo-2-92fe83b83ad6e8a25eff32f91ff69a58fde31dbd.tar.gz
gentoo-2-92fe83b83ad6e8a25eff32f91ff69a58fde31dbd.tar.bz2
gentoo-2-92fe83b83ad6e8a25eff32f91ff69a58fde31dbd.zip
Version bump.
(Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'net-nntp/pan/pan-0.116.ebuild')
-rw-r--r--net-nntp/pan/pan-0.116.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-nntp/pan/pan-0.116.ebuild b/net-nntp/pan/pan-0.116.ebuild
new file mode 100644
index 000000000000..da0579fe2559
--- /dev/null
+++ b/net-nntp/pan/pan-0.116.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.116.ebuild,v 1.1 2006/10/10 22:17:50 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spell"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libpcre-5.0
+ >=dev-libs/gmime-2.1.0
+ spell? ( >=app-text/gtkspell-2.0.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ sys-devel/gettext"
+
+src_compile() {
+ econf $(use_with spell gtkspell) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}