summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-06 10:35:14 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-06 10:35:14 +0000
commit36afde0eb4e4ea304eeaab5f17c2b4e33a5cc798 (patch)
tree419456c4849739d98ea89625e20bc65d519a7254 /net-nntp
parentRemove old version using deprecated qt4 eclass. (diff)
downloadgentoo-2-36afde0eb4e4ea304eeaab5f17c2b4e33a5cc798.tar.gz
gentoo-2-36afde0eb4e4ea304eeaab5f17c2b4e33a5cc798.tar.bz2
gentoo-2-36afde0eb4e4ea304eeaab5f17c2b4e33a5cc798.zip
Version bump (bug #413059, thanks to Emmanuel Andry and Jeroen Roovers); adds support for attachment uploading, SSL connections, gnome-keyring for secure password storage. Update to EAPI4. Update live ebuild.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/ChangeLog10
-rw-r--r--net-nntp/pan/pan-0.137.ebuild41
-rw-r--r--net-nntp/pan/pan-9999.ebuild36
3 files changed, 74 insertions, 13 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 7a2f82568106..27962e6e4d97 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nntp/pan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.98 2012/05/03 04:32:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.99 2012/05/06 10:35:14 tetromino Exp $
+
+*pan-0.137 (06 May 2012)
+
+ 06 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +pan-0.137.ebuild,
+ pan-9999.ebuild:
+ Version bump (bug #413059, thanks to Emmanuel Andry and Jeroen Roovers); adds
+ support for attachment uploading, SSL connections, gnome-keyring for secure
+ password storage. Update to EAPI4. Update live ebuild.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> pan-0.133-r1.ebuild,
pan-0.134.ebuild, pan-0.135.ebuild, pan-9999.ebuild:
diff --git a/net-nntp/pan/pan-0.137.ebuild b/net-nntp/pan/pan-0.137.ebuild
new file mode 100644
index 000000000000..a530b28b0969
--- /dev/null
+++ b/net-nntp/pan/pan-0.137.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.137.ebuild,v 1.1 2012/05/06 10:35:14 tetromino Exp $
+
+EAPI="4"
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome-keyring libnotify spell ssl"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-2.16:2
+ dev-libs/gmime:2.6
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ spell? (
+ >=app-text/enchant-1.6
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-2.12.10 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ --without-gtk3 \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+}
diff --git a/net-nntp/pan/pan-9999.ebuild b/net-nntp/pan/pan-9999.ebuild
index f176bfc20c1f..535882ad76b0 100644
--- a/net-nntp/pan/pan-9999.ebuild
+++ b/net-nntp/pan/pan-9999.ebuild
@@ -1,36 +1,43 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-9999.ebuild,v 1.8 2012/05/03 04:32:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-9999.ebuild,v 1.9 2012/05/06 10:35:14 tetromino Exp $
-EAPI="3"
+EAPI="4"
-inherit autotools base git-2
+inherit autotools git-2
DESCRIPTION="A newsreader for GNOME"
HOMEPAGE="http://pan.rebelbase.com/"
EGIT_REPO_URI="git://git.gnome.org/${PN}2
http://git.gnome.org/browse/${PN}2"
+SRC_URI=
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="spell"
+IUSE="gnome-keyring libnotify spell ssl"
-RDEPEND=">=dev-libs/glib-2.14:2
+RDEPEND=">=dev-libs/glib-2.26:2
>=x11-libs/gtk+-2.16:2
- dev-libs/gmime:2.4
- spell? ( >=app-text/gtkspell-2.0.7:2 )"
+ dev-libs/gmime:2.6
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ spell? (
+ >=app-text/enchant-1.6
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-2.12.10 )"
DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
>=dev-util/intltool-0.35.5
- virtual/pkgconfig
- sys-devel/gettext"
+ sys-devel/gettext
+ virtual/pkgconfig"
# The normal version tree ebuild we are based on (for patching)
-Pnorm="${PN}-0.134"
+Pnorm="${PN}-0.137"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
src_prepare() {
# bootstrap build system
@@ -39,5 +46,10 @@ src_prepare() {
}
src_configure() {
- econf $(use_with spell gtkspell)
+ econf \
+ --without-gtk3 \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
}