summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-07 15:21:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-07 15:21:11 +0000
commit5573c42d53af1cb8f0b52ffe8e8aa12d8cb3dbe4 (patch)
treeab2843d0a8c0e6f0c6f0c097f41940923b16dcda /net-nntp
parentTransfer Prefix keywords (diff)
downloadgentoo-2-5573c42d53af1cb8f0b52ffe8e8aa12d8cb3dbe4.tar.gz
gentoo-2-5573c42d53af1cb8f0b52ffe8e8aa12d8cb3dbe4.tar.bz2
gentoo-2-5573c42d53af1cb8f0b52ffe8e8aa12d8cb3dbe4.zip
Bump for #260370. Thanks to Sebastian Luettich
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/ChangeLog10
-rw-r--r--net-nntp/tin/metadata.xml6
-rw-r--r--net-nntp/tin/tin-1.9.4.ebuild88
3 files changed, 102 insertions, 2 deletions
diff --git a/net-nntp/tin/ChangeLog b/net-nntp/tin/ChangeLog
index edc6319a38be..caa9f72da5a2 100644
--- a/net-nntp/tin/ChangeLog
+++ b/net-nntp/tin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nntp/tin
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.22 2009/03/08 10:30:25 cla Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.23 2010/01/07 15:21:11 patrick Exp $
+
+*tin-1.9.4 (07 Jan 2010)
+
+ 07 Jan 2010; Patrick Lauer <patrick@gentoo.org> +tin-1.9.4.ebuild,
+ metadata.xml:
+ Bump for #260370. Thanks to Sebastian Luettich
08 Mar 2009; Dawid Węgliński <cla@gentoo.org> tin-1.8.3.ebuild:
Prevent double emake
diff --git a/net-nntp/tin/metadata.xml b/net-nntp/tin/metadata.xml
index 4d0ebe73a55f..84f03bcd5f09 100644
--- a/net-nntp/tin/metadata.xml
+++ b/net-nntp/tin/metadata.xml
@@ -2,4 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-news</herd>
+<use>
+<flag name='cancel-locks'>Enable CancelLock functionality</flag>
+<flag name='evil'>Let tin generate a message ID</flag>
+<flag name='forgery'>Cancel messages posted from a different account</flag>
+<flag name='etiquette'>Enable the display off posting etiquettes</flag>
+</use>
</pkgmetadata>
diff --git a/net-nntp/tin/tin-1.9.4.ebuild b/net-nntp/tin/tin-1.9.4.ebuild
new file mode 100644
index 000000000000..a82002b99180
--- /dev/null
+++ b/net-nntp/tin/tin-1.9.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-1.9.4.ebuild,v 1.1 2010/01/07 15:21:11 patrick Exp $
+
+EAPI="2"
+
+inherit versionator eutils
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="cancel-locks crypt debug evil forgery idn ipv6 nls unicode socks5 +etiquette"
+
+DEPEND="sys-libs/ncurses
+ dev-libs/libpcre
+ dev-libs/uulib
+ idn? ( net-dns/libidn )
+ unicode? ( dev-libs/icu )
+ nls? ( sys-devel/gettext )
+ crypt? ( app-crypt/gnupg )
+ socks5? ( net-proxy/dante )"
+
+RDEPEND="${DEPEND}
+ net-misc/urlview"
+
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode
+ then
+ die "For unicode support you need sys-libs/ncurses compiled with unicode support!"
+ fi
+}
+
+src_configure() {
+
+ if use evil
+ then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ if ! use etiquette; then
+ myconf="${myconf} --disable-etiquette"
+ fi
+
+ if ! use evil && use cancel-locks; then
+ die "USE=cancel-locks requires also USE=evil to generate MIDs and the Cancel-Lock:-Header."
+ fi
+
+ econf \
+ --with-pcre=/usr \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --disable-echo \
+ --disable-mime-strict-charset \
+ --with-coffee \
+ --with-screen=${screen} \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable crypt pgp-gpg) \
+ $(use_enable nls) \
+ $(use_enable cancel-locks) \
+ $(use_with socks5) \
+ ${myconf} \
+ || die "econf failed"
+}
+
+src_install() {
+ if has_version mail-client/mutt; then
+ rm doc/mmdf.5 doc/mbox.5
+ fi
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,*.sample,*.txt} || die "dodoc failed"
+ insinto /etc/tin
+ doins doc/tin.defaults || die "doins failed"
+}