summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-01 06:20:04 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-01 06:20:04 +0000
commitf79021d4bb1b647fcb690294f68380c2c51a9491 (patch)
tree89faef9eb56725625bdf5339c7c2c185c2d02e02 /net-p2p/amule
parentDESTDIR over einstall (Manifest recommit) (diff)
downloadgentoo-2-f79021d4bb1b647fcb690294f68380c2c51a9491.tar.gz
gentoo-2-f79021d4bb1b647fcb690294f68380c2c51a9491.tar.bz2
gentoo-2-f79021d4bb1b647fcb690294f68380c2c51a9491.zip
Added unicode detection.
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/amule-1.2.6.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-p2p/amule/amule-1.2.6.ebuild b/net-p2p/amule/amule-1.2.6.ebuild
index 8863dd830e91..f3058dfb97ac 100644
--- a/net-p2p/amule/amule-1.2.6.ebuild
+++ b/net-p2p/amule/amule-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.2.6.ebuild,v 1.2 2004/03/01 06:18:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.2.6.ebuild,v 1.3 2004/03/01 06:20:04 eradicator Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -19,6 +19,16 @@ DEPEND=">=x11-libs/wxGTK-2.4.2
>=net-ftp/curl-7.11.0
>=sys-libs/zlib-1.2.1"
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "${PN} will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
src_compile() {
econf `use_enable nls` || die
emake -j1 || die