summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-04-08 00:08:53 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-04-08 00:08:53 +0000
commitff37f95784eb020e7fb9f91842e960cb3b016560 (patch)
tree6574b397c760d14466bfcfcaf87bad93a7b3a10c /net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild
parentBump (diff)
downloadgentoo-2-ff37f95784eb020e7fb9f91842e960cb3b016560.tar.gz
gentoo-2-ff37f95784eb020e7fb9f91842e960cb3b016560.tar.bz2
gentoo-2-ff37f95784eb020e7fb9f91842e960cb3b016560.zip
Version bumps and cleanup
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild
new file mode 100644
index 000000000000..c925753aa05d
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.6.5_rc2.ebuild,v 1.1 2013/04/08 00:08:53 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+LANGS="ca_ES cs da de en es es_CL et eu_ES fa fa_IR fi fr_CA fr_FR he hr hu it lt nb nl pl pt_BR ro_RO ru sk sr sv tr uk zh_CN zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}-r1.tgz
+"
+
+LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE 1stclassmsg dbus +qrcode upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0[threads(+)]
+ dev-libs/openssl[-bindist]
+ qrcode? (
+ media-gfx/qrencode
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ dev-qt/qtgui:4
+ dbus? (
+ dev-qt/qtdbus:4
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+src_prepare() {
+ cd src || die
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+ use qrcode && OPTS+=("USE_QRCODE=1")
+ use 1stclassmsg && OPTS+=("FIRST_CLASS_MESSAGING=1")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ # Workaround for bug #440034
+ share/genbuild.sh build/build.h
+
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}