summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-01 23:59:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-01 23:59:23 +0000
commit5312c94c70646656aff720f9bfef286e5d4c4ab3 (patch)
treebce29677c8101621a6398704c906cd5a9e8bba6e /net-p2p/bitcoind
parentVersion bump (diff)
downloadgentoo-2-5312c94c70646656aff720f9bfef286e5d4c4ab3.tar.gz
gentoo-2-5312c94c70646656aff720f9bfef286e5d4c4ab3.tar.bz2
gentoo-2-5312c94c70646656aff720f9bfef286e5d4c4ab3.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog9
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.6.ebuild122
2 files changed, 129 insertions, 2 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index add27a688c86..e0c1e0a7df14 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitcoind
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.81 2013/10/22 16:44:53 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.82 2014/01/01 23:59:23 blueness Exp $
+
+*bitcoind-0.8.6 (02 Jan 2014)
+
+ 02 Jan 2014; Anthony G. Basile <blueness@gentoo.org> +bitcoind-0.8.6.ebuild:
+ Version bump
22 Oct 2013; Anthony G. Basile <blueness@gentoo.org>
-files/0.4.2-Makefile.gentoo, -files/0.4.4+bip16-eligius_sendfee.patch,
diff --git a/net-p2p/bitcoind/bitcoind-0.8.6.ebuild b/net-p2p/bitcoind/bitcoind-0.8.6.ebuild
new file mode 100644
index 000000000000..37e893b52734
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.8.6.ebuild
@@ -0,0 +1,122 @@
+# Copyright 2010-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.6.ebuild,v 1.1 2014/01/01 23:59:23 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit bash-completion-r1 db-use eutils versionator systemd toolchain-funcs
+
+MyPV="${PV/_/}"
+MyPN="bitcoin"
+MyP="${MyPN}-${MyPV}"
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
+"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bash-completion examples ipv6 logrotate upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0[threads(+)]
+ dev-libs/openssl:0[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ <=dev-libs/leveldb-1.12.0[-snappy]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+ sys-apps/sed
+"
+
+S="${WORKDIR}/${MyP}"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0.8.2-sys_leveldb.patch"
+ rm -r src/leveldb
+
+ if has_version '>=dev-libs/boost-1.52'; then
+ sed -i 's/\(-l db_cxx\)/-l boost_chrono$(BOOST_LIB_SUFFIX) \1/' src/makefile.unix
+ fi
+}
+
+src_compile() {
+ OPTS=()
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+ use ipv6 || OPTS+=("USE_IPV6=-")
+
+ OPTS+=("USE_SYSTEM_LEVELDB=1")
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+ systemd_dounit "${FILESDIR}/bitcoind.service"
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README.md doc/release-notes.md
+ doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
+
+ if use bash-completion; then
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,spendfrom,tidy_datadir.sh,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}