summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-01-16 15:32:29 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-01-16 15:32:29 +0000
commit9009b01ddfaccaf6334d5f1bd9912598dc959c47 (patch)
tree1474d59f588738262b0180d66a8774e0062bd8e5 /net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild
parentRemove virtual/bittorrent (diff)
downloadgentoo-2-9009b01ddfaccaf6334d5f1bd9912598dc959c47.tar.gz
gentoo-2-9009b01ddfaccaf6334d5f1bd9912598dc959c47.tar.bz2
gentoo-2-9009b01ddfaccaf6334d5f1bd9912598dc959c47.zip
Remove virtual/bittorrent
(Portage version: 2.1.3.19, RepoMan options: --force)
Diffstat (limited to 'net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild')
-rw-r--r--net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild b/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..6cb1a948405a
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.4.0-r1.ebuild,v 1.1 2008/01/16 15:32:28 armin76 Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 s390 sh sparc x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ )
+ >=dev-python/pycrypto-2.0
+ !net-p2p/bittornado"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+
+DOCS="TRACKERLESS.txt public.key credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+ dohtml redirdonate.html
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.ico "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}