summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-06-15 10:20:15 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-06-15 10:20:15 +0000
commitfad3f04b51fc4c03984b817cd5f14795863ad3c7 (patch)
tree235426aadaa810826040990ea09e44bfdab58516 /net-p2p/deluge/deluge-9999.ebuild
parentFixing the usage of ${ROOT}'ed apr/apr-util in src_compile. (diff)
downloadgentoo-2-fad3f04b51fc4c03984b817cd5f14795863ad3c7.tar.gz
gentoo-2-fad3f04b51fc4c03984b817cd5f14795863ad3c7.tar.bz2
gentoo-2-fad3f04b51fc4c03984b817cd5f14795863ad3c7.zip
Add livesvn ebuild
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-p2p/deluge/deluge-9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
new file mode 100644
index 000000000000..a9522e97bdd8
--- /dev/null
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.1 2007/06/15 10:20:15 armin76 Exp $
+
+inherit eutils distutils subversion
+
+ESVN_REPO_URI="http://deluge-torrent.org/svn/trunk"
+ESVN_PROJECT="deluge"
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ libnotify? ( dev-python/notify-python )"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+}
+
+src_compile() {
+ if use amd64 || use ia64 || use ppc64; then
+ CFLAGS="${CFLAGS} -DAMD64"
+ fi
+ distutils_src_compile
+}
+
+pkg_postinst() {
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}