summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-02 14:06:24 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-02 14:06:24 +0000
commitd4a6651d6efdff902a32e27b8e54a4953045bcc6 (patch)
treec970a5437cf70766da325a5bbaa673bc6ed692b8 /net-p2p/gnunet/gnunet-0.5.5.ebuild
parent changelog:p (diff)
downloadgentoo-2-d4a6651d6efdff902a32e27b8e54a4953045bcc6.tar.gz
gentoo-2-d4a6651d6efdff902a32e27b8e54a4953045bcc6.tar.bz2
gentoo-2-d4a6651d6efdff902a32e27b8e54a4953045bcc6.zip
changelog:p
Diffstat (limited to 'net-p2p/gnunet/gnunet-0.5.5.ebuild')
-rw-r--r--net-p2p/gnunet/gnunet-0.5.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/gnunet/gnunet-0.5.5.ebuild b/net-p2p/gnunet/gnunet-0.5.5.ebuild
new file mode 100644
index 000000000000..d830991a9b14
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.5.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.5.5.ebuild,v 1.1 2003/10/02 14:06:07 lanius Exp $
+
+inherit libtool
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.2.5"
+
+
+src_compile () {
+ elibtoolize
+ local myconf
+ use ipv6 && myconf="--enable-ipv6" || myconf=" --disable-ipv6"
+ econf ${myconf}
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+ dodir /etc
+ cp contrib/gnunet.conf.root ${D}/etc/gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bug"
+ einfo ""
+ einfo "now copy an appropriate config file from"
+ einfo "/usr/share/doc/${P}/contrib"
+ einfo "to ~/.gnunet/gnunet.conf"
+ einfo ""
+}