summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-15 10:26:25 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-15 10:26:25 +0000
commit6ed898fe9c240922a0fa0f1bb6622e44f36af863 (patch)
tree182edac3f3bf776a99ab434de2597fd6773c9464 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-6ed898fe9c240922a0fa0f1bb6622e44f36af863.tar.gz
gentoo-2-6ed898fe9c240922a0fa0f1bb6622e44f36af863.tar.bz2
gentoo-2-6ed898fe9c240922a0fa0f1bb6622e44f36af863.zip
Version bump, update deps of live ebuild
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ncdc/ChangeLog8
-rw-r--r--net-p2p/ncdc/ncdc-1.16.1.ebuild4
-rw-r--r--net-p2p/ncdc/ncdc-1.17.ebuild29
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild16
4 files changed, 45 insertions, 12 deletions
diff --git a/net-p2p/ncdc/ChangeLog b/net-p2p/ncdc/ChangeLog
index 1a8893d2622a..a98b1757daa0 100644
--- a/net-p2p/ncdc/ChangeLog
+++ b/net-p2p/ncdc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ncdc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.36 2013/06/06 10:11:24 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ChangeLog,v 1.37 2013/06/15 10:26:25 xmw Exp $
+
+*ncdc-1.17 (15 Jun 2013)
+
+ 15 Jun 2013; Michael Weber <xmw@gentoo.org> +ncdc-1.17.ebuild,
+ ncdc-1.16.1.ebuild, ncdc-9999.ebuild:
+ Version bump, update deps of live ebuild
06 Jun 2013; Michael Weber <xmw@gentoo.org> -ncdc-1.14.ebuild,
-ncdc-1.15.ebuild:
diff --git a/net-p2p/ncdc/ncdc-1.16.1.ebuild b/net-p2p/ncdc/ncdc-1.16.1.ebuild
index eac5bfdb88ae..0a76dc250656 100644
--- a/net-p2p/ncdc/ncdc-1.16.1.ebuild
+++ b/net-p2p/ncdc/ncdc-1.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.16.1.ebuild,v 1.3 2013/05/20 08:21:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.16.1.ebuild,v 1.4 2013/06/15 10:26:25 xmw Exp $
EAPI=4
@@ -16,11 +16,11 @@ IUSE=""
RDEPEND="app-arch/bzip2
dev-db/sqlite:3
dev-libs/glib:2
- dev-util/makeheaders
net-libs/gnutls
sys-libs/ncurses:5[unicode]
sys-libs/zlib"
DEPEND="${RDEPEND}
+ dev-util/makeheaders
virtual/pkgconfig"
src_configure() {
diff --git a/net-p2p/ncdc/ncdc-1.17.ebuild b/net-p2p/ncdc/ncdc-1.17.ebuild
new file mode 100644
index 000000000000..92ed64bb54fd
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.17.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-1.17.ebuild,v 1.1 2013/06/15 10:26:25 xmw Exp $
+
+EAPI=5
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="http://dev.yorhel.nl/ncdc"
+SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ net-libs/gnutls
+ sys-libs/ncurses:5[unicode]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/makeheaders
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-silent-rules
+}
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index 5a6146a2eb73..0d2434394311 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.7 2013/01/21 10:19:51 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ncdc/ncdc-9999.ebuild,v 1.8 2013/06/15 10:26:25 xmw Exp $
-EAPI=4
-
-EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
+EAPI=5
inherit autotools base git-2
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
+EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
LICENSE="MIT"
SLOT="0"
@@ -19,13 +18,12 @@ IUSE=""
RDEPEND="app-arch/bzip2
dev-db/sqlite:3
dev-libs/glib:2
- dev-libs/libxml2:2
net-libs/gnutls
- sys-libs/gdbm
- sys-libs/ncurses:5"
+ sys-libs/ncurses:5[unicode]
+ sys-libs/zlib"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/makeheaders"
+ dev-util/makeheaders
+ virtual/pkgconfig"
src_prepare() {
eautoreconf