summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-30 17:37:56 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-30 17:37:56 +0000
commita80eeea97e2cc76fbe6880244a9e9cd7981dc20c (patch)
treeba6f5cca8b6e6df9f7238bc9ae6a77b676308783 /net-p2p
parentRe-fix threads use-flag check if >boost-1.33, bug 180322 (diff)
downloadgentoo-2-a80eeea97e2cc76fbe6880244a9e9cd7981dc20c.tar.gz
gentoo-2-a80eeea97e2cc76fbe6880244a9e9cd7981dc20c.tar.bz2
gentoo-2-a80eeea97e2cc76fbe6880244a9e9cd7981dc20c.zip
Re-fix threads use-flag check if >boost-1.33, bug 180322
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog5
-rw-r--r--net-p2p/deluge/deluge-0.5.0.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index a044a8849bbc..e59a3d9236a4 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.7 2007/05/07 13:58:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.8 2007/05/30 17:37:56 armin76 Exp $
+
+ 30 May 2007; Raúl Porcel <armin76@gentoo.org> deluge-0.5.0.ebuild:
+ Re-fix threads use-flag check if >boost-1.33, bug 180322
07 May 2007; Raúl Porcel <armin76@gentoo.org> deluge-0.5.0.ebuild:
0.5.0 only works with rb_libtorrent-0.11, bug 177469
diff --git a/net-p2p/deluge/deluge-0.5.0.ebuild b/net-p2p/deluge/deluge-0.5.0.ebuild
index 374ceda5c475..5166a7273810 100644
--- a/net-p2p/deluge/deluge-0.5.0.ebuild
+++ b/net-p2p/deluge/deluge-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.0.ebuild,v 1.6 2007/05/07 13:58:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.0.ebuild,v 1.7 2007/05/30 17:37:56 armin76 Exp $
inherit eutils distutils
@@ -23,10 +23,11 @@ RDEPEND="${DEPEND}
libnotify? ( dev-python/notify-python )"
pkg_setup() {
- if has_version "<dev-libs/boost-1.34" && \
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
! built_with_use "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
fi
}