summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-21 16:39:28 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-21 16:39:28 +0000
commitbbff7dd081e1eacb591b4ac0b34781584a8e4313 (patch)
treeb151e86fce43d9229bd35a3ceed102e4028f1331 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-bbff7dd081e1eacb591b4ac0b34781584a8e4313.tar.gz
gentoo-2-bbff7dd081e1eacb591b4ac0b34781584a8e4313.tar.bz2
gentoo-2-bbff7dd081e1eacb591b4ac0b34781584a8e4313.zip
Version bump. Stop installing trayicon module; use GTK's instead.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog8
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.10.ebuild32
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.9-r1.ebuild51
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.9.ebuild45
4 files changed, 39 insertions, 97 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 2176e9c65711..6403ded4f8d0 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.30 2009/02/12 03:12:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.31 2009/02/21 16:39:28 dirtyepic Exp $
+
+*nicotine+-1.2.10 (21 Feb 2009)
+
+ 21 Feb 2009; Ryan Hill <dirtyepic@gentoo.org> -nicotine+-1.2.9.ebuild,
+ -nicotine+-1.2.9-r1.ebuild, +nicotine+-1.2.10.ebuild:
+ Version bump. Stop installing trayicon module; use GTK's instead.
12 Feb 2009; Ryan Hill <dirtyepic@gentoo.org> metadata.xml:
Add myself to maintainers.
diff --git a/net-p2p/nicotine+/nicotine+-1.2.10.ebuild b/net-p2p/nicotine+/nicotine+-1.2.10.ebuild
new file mode 100644
index 000000000000..485ac65a96ea
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.10.ebuild,v 1.1 2009/02/21 16:39:28 dirtyepic Exp $
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://nicotine-plus.sourceforge.net"
+SRC_URI="http://www.nicotine-plus.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="geoip spell vorbis"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10
+ vorbis? ( >=dev-python/pyvorbis-1.4-r3
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ spell? ( dev-python/sexy-python )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}"
+
+
+src_install() {
+ distutils_python_version
+ distutils_src_install \
+ --install-lib /usr/$(get_libdir)/python${PYVER}/site-packages
+}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.9-r1.ebuild b/net-p2p/nicotine+/nicotine+-1.2.9-r1.ebuild
deleted file mode 100644
index 4558c28356a0..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.9-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.9-r1.ebuild,v 1.1 2008/03/31 14:24:54 coldwind Exp $
-
-inherit distutils eutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="geoip spell vorbis"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2
- vorbis? ( >=dev-python/pyvorbis-1.4-r1
- >=dev-python/pyogg-1 )
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- spell? ( dev-python/sexy-python )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-locale-handling.patch
-}
-
-src_compile() {
- distutils_src_compile
-
- cd "${S}"/trayicon/
- sed -i -e "s:/lib/:/$(get_libdir)/:" \
- Makefile.in || die "sed failed"
- ./autogen.py
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- distutils_python_version
- distutils_src_install --install-lib \
- /usr/$(get_libdir)/python${PYVER}/site-packages
-
- cd "${S}"/trayicon/
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/net-p2p/nicotine+/nicotine+-1.2.9.ebuild b/net-p2p/nicotine+/nicotine+-1.2.9.ebuild
deleted file mode 100644
index c2f70d2df4f3..000000000000
--- a/net-p2p/nicotine+/nicotine+-1.2.9.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.9.ebuild,v 1.4 2007/11/18 10:59:00 armin76 Exp $
-
-inherit distutils eutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
-HOMEPAGE="http://nicotine-plus.sourceforge.net"
-SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="geoip spell vorbis"
-
-RDEPEND="virtual/python
- >=dev-python/pygtk-2
- vorbis? ( >=dev-python/pyvorbis-1.4-r1
- >=dev-python/pyogg-1 )
- geoip? ( >=dev-python/geoip-python-0.2.0
- >=dev-libs/geoip-1.2.1 )
- spell? ( dev-python/sexy-python )
- !net-p2p/nicotine"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-apps/sed-4"
-
-src_compile() {
- distutils_src_compile
-
- cd "${S}"/trayicon/
- sed -i -e "s:/lib/:/$(get_libdir)/:" \
- Makefile.in || die "sed failed"
- ./autogen.py
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- distutils_python_version
- distutils_src_install --install-lib \
- /usr/$(get_libdir)/python${PYVER}/site-packages
-
- cd "${S}"/trayicon/
- emake DESTDIR="${D}" install || die "emake install failed"
-}