summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2005-12-14 17:01:11 +0000
committerCarlos Silva <r3pek@gentoo.org>2005-12-14 17:01:11 +0000
commitc31ef889cd2f2d9c62dccb53bcd8f452291dba1f (patch)
tree6424c6571f4d4c6a0d9e24d4bc7a1722383ab670 /net-p2p
parentChange PV to PF per bug #112668 (diff)
downloadgentoo-2-c31ef889cd2f2d9c62dccb53bcd8f452291dba1f.tar.gz
gentoo-2-c31ef889cd2f2d9c62dccb53bcd8f452291dba1f.tar.bz2
gentoo-2-c31ef889cd2f2d9c62dccb53bcd8f452291dba1f.zip
Add a check to see if media-libs/gd was compiled with jpeg use flag
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog5
-rw-r--r--net-p2p/amule/amule-2.0.3-r4.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index ee4c0a738339..dd5a010214ea 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.57 2005/11/20 07:13:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.58 2005/12/14 17:01:11 r3pek Exp $
+
+ 14 Dec 2005; Carlos Silva <r3pek@gentoo.org> amule-2.0.3-r4.ebuild:
+ Add a check to see if media-libs/gd was compiled with jpeg use flag
20 Nov 2005; Mark Loeser <halcy0n@gentoo.org> amule-2.0.3-r4.ebuild:
Stable on x86; bug #106380
diff --git a/net-p2p/amule/amule-2.0.3-r4.ebuild b/net-p2p/amule/amule-2.0.3-r4.ebuild
index 3a45cf503d87..9fc13a95a8ed 100644
--- a/net-p2p/amule/amule-2.0.3-r4.ebuild
+++ b/net-p2p/amule/amule-2.0.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.3-r4.ebuild,v 1.6 2005/11/20 07:13:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.3-r4.ebuild,v 1.7 2005/12/14 17:01:11 r3pek Exp $
inherit eutils flag-o-matic wxwidgets
@@ -42,6 +42,10 @@ pkg_setup() {
eerror "USE flag to build amule"
die "Invalid USE flag set"
fi
+
+ if use stats && ! built_with_use >=media-libs/gd-2.0.32 jpeg; then
+ die "media-libs/gd should be compiled with the jpeg use flag when you have the stats use flag set"
+ fi
}
src_unpack() {