summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-12-03 22:43:38 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-12-03 22:43:38 +0000
commitc7de7adf85f0c9877ac2a6996e422497bf63e7f9 (patch)
treece45384c498d20869752f81b84e741b812d3baaa /net-p2p
parentTypo. :( how comes that it wont give warning :( (diff)
downloadgentoo-2-c7de7adf85f0c9877ac2a6996e422497bf63e7f9.tar.gz
gentoo-2-c7de7adf85f0c9877ac2a6996e422497bf63e7f9.tar.bz2
gentoo-2-c7de7adf85f0c9877ac2a6996e422497bf63e7f9.zip
Change slot to have correct one based on app version instead of kde version. Version bump for new beta.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog10
-rw-r--r--net-p2p/ktorrent/ktorrent-3.1.5-r1.ebuild48
-rw-r--r--net-p2p/ktorrent/ktorrent-3.2_beta1.ebuild64
-rw-r--r--net-p2p/ktorrent/metadata.xml6
4 files changed, 125 insertions, 3 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 14d77f566657..1829488fb178 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.95 2008/12/01 22:09:01 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.96 2008/12/03 22:43:38 scarabeus Exp $
+
+*ktorrent-3.2_beta1 (03 Dec 2008)
+*ktorrent-3.1.5-r1 (03 Dec 2008)
+
+ 03 Dec 2008; Tomas Chvatal <scarabeus@gentoo.org>
+ +ktorrent-3.1.5-r1.ebuild, +ktorrent-3.2_beta1.ebuild:
+ Change slot to have correct one based on app version instead of kde
+ version. Version bump for new beta.
01 Dec 2008; Friedrich Oslage <bluebird@gentoo.org> ktorrent-2.2.8.ebuild:
Stable on sparc, security bug #244741
diff --git a/net-p2p/ktorrent/ktorrent-3.1.5-r1.ebuild b/net-p2p/ktorrent/ktorrent-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..00fb6ef109c1
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.1.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.1.5-r1.ebuild,v 1.1 2008/12/03 22:43:38 scarabeus Exp $
+
+EAPI="2"
+
+NEED_KDE=":4.1"
+KDE_LINGUAS="ca cs da de el es et fr gl it ja lv nb nds nl nn pl pt pt_BR ru sv uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="3"
+IUSE="+bwscheduler +infowidget +ipfilter +logviewer +mediaplayer +scanfolder +search +stats +upnp webinterface"
+
+DEPEND="app-crypt/qca:2
+ dev-libs/gmp
+ sys-devel/gettext
+ !kdeprefix? ( !net-p2p/ktorrent:0 )
+ !net-p2p/ktorrent:4.1"
+# 4.1 blocker is due to slot change. We wont slot based on kde version but based
+# on application version. This was stupid mistake.
+RDEPEND="${DEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )"
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)"
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/ktorrent-3.2_beta1.ebuild b/net-p2p/ktorrent/ktorrent-3.2_beta1.ebuild
new file mode 100644
index 000000000000..6deb888e9df1
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.2_beta1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.2_beta1.ebuild,v 1.1 2008/12/03 22:43:38 scarabeus Exp $
+
+EAPI="2"
+
+NEED_KDE=":4.1"
+KDE_LINGUAS="ca cs da de el es et fr gl it ja lv nb nds nl nn pl pt pt_BR ru sv uk zh_CN zh_TW"
+inherit kde4-base
+
+MY_PV="${PV/_/}"
+MY_P="${P/_/}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="3"
+IUSE="+bwscheduler +downloadorder +infowidget +ipfilter +kross +logviewer +mediaplayer +plasma +rss +scanfolder +search +stats +upnp webinterface"
+
+DEPEND="app-crypt/qca:2
+ dev-libs/gmp
+ sys-devel/gettext
+ !kdeprefix? ( !net-p2p/ktorrent:0 )
+ plasma? ( kde-base/plasma-workspace )
+ !net-p2p/ktorrent:4.1"
+ # 4.1 blocker is due to slot change. We wont slot based on kde version
+ # but based on application version. This was stupid mistake.
+RDEPEND="${DEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ # plasma is automagic so make it normal dep.
+ use plasma && VALUE="true" || VALUE="false"
+ sed -i \
+ -e "s:macro_log_feature(PLASMA_FOUND:SET ( PLASMA_FOUND ${VALUE}) #:g" \
+ CMakeLists.txt || die "sed failed"
+}
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)"
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index f55f61c1b989..98c8e730a983 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -8,9 +8,11 @@
<name>deathwing00</name>
</maintainer>
<use>
- <flag name="bwscheduler">Enable the bwscheduler plugin</flag>
+ <flag name="bwscheduler">Enable the bwscheduler plugin</flag>
+ <flag name="downloadorder">Enable plugin for user selected download order</flag>
<flag name="infowidget">Enable the infowidget plugin</flag>
- <flag name="ipfilter">Enable the ipfilter plugin</flag>
+ <flag name="ipfilter">Enable the ipfilter plugin</flag>
+ <flag name="kross">Enable kross scripting support</flag>
<flag name="logviewer">Enable the logviewer plugin</flag>
<flag name="mediaplayer">Enable the mediaplayer plugin</flag>
<flag name="scanfolder">Enable the scanfolder plugin</flag>