summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-05 10:19:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-05 10:19:39 +0000
commitecba2aa6b9fcedfaf1ace10441b37f3b3ad2d4f2 (patch)
treeb844a21adf1509f2c4629e09904f825677e4f4b2 /net-p2p
parentversion bump (diff)
downloadgentoo-2-ecba2aa6b9fcedfaf1ace10441b37f3b3ad2d4f2.tar.gz
gentoo-2-ecba2aa6b9fcedfaf1ace10441b37f3b3ad2d4f2.tar.bz2
gentoo-2-ecba2aa6b9fcedfaf1ace10441b37f3b3ad2d4f2.zip
version bump
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.9.8.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 2ee2ef874217..81f838993daf 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.186 2012/05/04 06:33:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.187 2012/05/05 10:19:39 hwoarang Exp $
+
+*qbittorrent-2.9.8 (05 May 2012)
+
+ 05 May 2012; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-2.9.8.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> qbittorrent-2.9.7.ebuild,
qbittorrent-9999.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.9.8.ebuild b/net-p2p/qbittorrent/qbittorrent-2.9.8.ebuild
new file mode 100644
index 000000000000..dd33e053b52a
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.9.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.9.8.ebuild,v 1.1 2012/05/05 10:19:39 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.6.1"
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}