summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-17 13:33:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-17 13:33:39 +0000
commitc49c41f427b594ee812b7600b8b75d9d9d681cfa (patch)
tree8fa614698c3659196d82a69124b350f3acb0911e /net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild
parentRemove KDE SC 4.7.3. (diff)
downloadgentoo-2-c49c41f427b594ee812b7600b8b75d9d9d681cfa.tar.gz
gentoo-2-c49c41f427b594ee812b7600b8b75d9d9d681cfa.tar.bz2
gentoo-2-c49c41f427b594ee812b7600b8b75d9d9d681cfa.zip
Version Bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild')
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild
new file mode 100644
index 000000000000..a5763fc09016
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db/foomatic-db-4.0.20120117.ebuild,v 1.1 2012/01/17 13:33:39 jlec Exp $
+
+EAPI=4
+
+inherit versionator
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r "${S}"/db/source/PPD
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+
+ # Avoid collision with foo2zjs, bug 185486
+ rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml}
+}