summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-11-20 00:23:51 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-11-20 00:23:51 +0000
commit189f96f4939e22a654855df95ac153370c1ad365 (patch)
treeeedc400e220c4e49356c66ac48a4ee77d1a55e05 /net-print/splix
parentadd otr USE flag for net-im/mcabber (diff)
downloadgentoo-2-189f96f4939e22a654855df95ac153370c1ad365.tar.gz
gentoo-2-189f96f4939e22a654855df95ac153370c1ad365.tar.bz2
gentoo-2-189f96f4939e22a654855df95ac153370c1ad365.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-print/splix')
-rw-r--r--net-print/splix/files/digest-splix-1.1.03
-rw-r--r--net-print/splix/files/splix-1.1.0-fix-makefile.patch39
-rw-r--r--net-print/splix/splix-1.1.0.ebuild57
3 files changed, 99 insertions, 0 deletions
diff --git a/net-print/splix/files/digest-splix-1.1.0 b/net-print/splix/files/digest-splix-1.1.0
new file mode 100644
index 000000000000..15662843592b
--- /dev/null
+++ b/net-print/splix/files/digest-splix-1.1.0
@@ -0,0 +1,3 @@
+MD5 ade37edad8cee878f2d90f91ef8486fe splix-1.1.0.tar.bz2 63855
+RMD160 c2df961fa2a52ae78da678df17790196835f1302 splix-1.1.0.tar.bz2 63855
+SHA256 0210c5015bccd08f0e9c25d40bcd01556a9b10528d40737493c1ef8b16b43491 splix-1.1.0.tar.bz2 63855
diff --git a/net-print/splix/files/splix-1.1.0-fix-makefile.patch b/net-print/splix/files/splix-1.1.0-fix-makefile.patch
new file mode 100644
index 000000000000..cd156a780b49
--- /dev/null
+++ b/net-print/splix/files/splix-1.1.0-fix-makefile.patch
@@ -0,0 +1,39 @@
+diff -urN splix-1.1.0.orig/Makefile splix-1.1.0/Makefile
+--- splix-1.1.0.orig/Makefile 2007-11-16 03:26:11.000000000 +0100
++++ splix-1.1.0/Makefile 2007-11-20 00:49:25.000000000 +0100
+@@ -4,10 +4,10 @@
+ # This project has been placed under the GPL Licence.
+ #
+
+-CXXFLAGS := -O2 `cups-config --cflags`
+-LDFLAGS := `cups-config --ldflags`
+-CUPSFILTER := `cups-config --serverbin`/filter
+-CUPSPPD := `cups-config --datadir`/model
++CXXFLAGS +=
++LDFLAGS +=
++CUPSFILTER := $(DESTDIR)`cups-config --serverbin`/filter
++CUPSPPD := $(DESTDIR)`cups-config --datadir`/model
+
+ # === DON'T CHANGE ANYTHING AFTER THIS MESSAGE ====
+
+diff -urN splix-1.1.0.orig/src/Makefile splix-1.1.0/src/Makefile
+--- splix-1.1.0.orig/src/Makefile 2007-11-16 03:35:51.000000000 +0100
++++ splix-1.1.0/src/Makefile 2007-11-20 00:50:32.000000000 +0100
+@@ -4,7 +4,7 @@
+ # This project has been placed under the GPL Licence.
+ #
+
+-CXXFLAGS += -I../include -Wall -g -O0 #-DENABLE_DEBUG
++CXXFLAGS += -I../include -Wall
+ LDFLAGS +=
+ LIBS += -lcups -lcupsimage -ljbig
+
+@@ -25,7 +25,7 @@
+ $(CXX) $(CXXFLAGS) -c $<
+
+ install: rastertospl2
+- install -m 755 -s rastertospl2 ${CUPSFILTER}
++ install -m 755 rastertospl2 ${CUPSFILTER}
+
+ .PHONY: clean distclean
+ clean:
diff --git a/net-print/splix/splix-1.1.0.ebuild b/net-print/splix/splix-1.1.0.ebuild
new file mode 100644
index 000000000000..071c700f5355
--- /dev/null
+++ b/net-print/splix/splix-1.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-1.1.0.ebuild,v 1.1 2007/11/20 00:23:51 wschlich Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_p/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ net-print/cupsddk
+ media-libs/jbigkit"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ CUPSFILTERDIR="$(cups-config --serverbin)/filter"
+ CUPSPPDDIR="$(cups-config --datadir)/model"
+
+ dodir "${CUPSFILTERDIR}"
+ dodir "${CUPSPPDDIR}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ebeep 5
+ ewarn ""
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+ ewarn ""
+}