summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2014-12-06 23:42:11 +0000
committerMatthias Maier <tamiko@gentoo.org>2014-12-06 23:42:11 +0000
commit1ae3222c83462a45df0d9a5ff9477657cc502a3f (patch)
tree0ed7e58d2b47dbce5af447095da7985ca12b32fb /net-print
parentversion bump and ebuild clean up, drop old RC (diff)
downloadgentoo-2-1ae3222c83462a45df0d9a5ff9477657cc502a3f.tar.gz
gentoo-2-1ae3222c83462a45df0d9a5ff9477657cc502a3f.tar.bz2
gentoo-2-1ae3222c83462a45df0d9a5ff9477657cc502a3f.zip
fix gnutls linkage in case of USE="-ssl", fixes bug #531830
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog6
-rw-r--r--net-print/cups/cups-2.0.1-r1.ebuild5
-rw-r--r--net-print/cups/files/cups-2.0.1-fix-linkage-to-gnutls.patch24
3 files changed, 32 insertions, 3 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index a9a8b4762f66..78c0973cdcfe 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/cups
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.652 2014/11/20 12:53:26 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.653 2014/12/06 23:42:11 tamiko Exp $
+
+ 06 Dec 2014; Matthias Maier <tamiko@gentoo.org>
+ +files/cups-2.0.1-fix-linkage-to-gnutls.patch, cups-2.0.1-r1.ebuild:
+ fix gnutls linkage in case of USE="-ssl", fixes bug #531830
20 Nov 2014; Matthias Maier <tamiko@gentoo.org>
+files/cups-2.0.1-xinetd-installation-fix.patch, cups-2.0.1-r1.ebuild:
diff --git a/net-print/cups/cups-2.0.1-r1.ebuild b/net-print/cups/cups-2.0.1-r1.ebuild
index cc68764d38d2..6d543a1b729e 100644
--- a/net-print/cups/cups-2.0.1-r1.ebuild
+++ b/net-print/cups/cups-2.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-2.0.1-r1.ebuild,v 1.2 2014/11/20 12:53:26 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-2.0.1-r1.ebuild,v 1.3 2014/12/06 23:42:11 tamiko Exp $
EAPI=5
@@ -94,12 +94,13 @@ RESTRICT="test"
S="${WORKDIR}/${MY_P}"
PATCHES=(
+ "${FILESDIR}/${PN}-1.4.4-nostrip.patch"
"${FILESDIR}/${PN}-1.6.0-dont-compress-manpages.patch"
"${FILESDIR}/${PN}-1.6.0-fix-install-perms.patch"
- "${FILESDIR}/${PN}-1.4.4-nostrip.patch"
"${FILESDIR}/${P}-rename-systemd-service-files.patch"
"${FILESDIR}/${P}-fix-compilation.patch"
"${FILESDIR}/${P}-xinetd-installation-fix.patch"
+ "${FILESDIR}/${P}-fix-linkage-to-gnutls.patch"
)
MULTILIB_CHOST_TOOLS=(
diff --git a/net-print/cups/files/cups-2.0.1-fix-linkage-to-gnutls.patch b/net-print/cups/files/cups-2.0.1-fix-linkage-to-gnutls.patch
new file mode 100644
index 000000000000..dafb6e14b0e6
--- /dev/null
+++ b/net-print/cups/files/cups-2.0.1-fix-linkage-to-gnutls.patch
@@ -0,0 +1,24 @@
+--- a/cups/usersys.c
++++ b/cups/usersys.c
+@@ -1044,7 +1044,9 @@
+ options = 0;
+ }
+
++#ifdef HAVE_SSL
+ _httpTLSSetOptions(options);
++#endif /* HAVE_SSL */
+ }
+ }
+
+--- a/scheduler/conf.c
++++ b/scheduler/conf.c
+@@ -2975,7 +2975,9 @@
+ }
+ }
+
++#ifdef HAVE_SSL
+ _httpTLSSetOptions(options);
++#endif /* HAVE_SSL */
+ }
+ else if ((!_cups_strcasecmp(line, "Port") || !_cups_strcasecmp(line, "Listen")
+ #ifdef HAVE_SSL