summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-07-10 15:52:24 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-07-10 15:52:24 +0000
commit99c81a2bcedde32837d02f34457e78b61c8d7679 (patch)
tree79efe808092d8ef7a0b69188904c7472cfa31c38 /net-print
parentadd dep on log4j thanks hollow + small cleanups (diff)
downloadgentoo-2-99c81a2bcedde32837d02f34457e78b61c8d7679.tar.gz
gentoo-2-99c81a2bcedde32837d02f34457e78b61c8d7679.tar.bz2
gentoo-2-99c81a2bcedde32837d02f34457e78b61c8d7679.zip
version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gtklp/ChangeLog7
-rw-r--r--net-print/gtklp/Manifest12
-rw-r--r--net-print/gtklp/files/digest-gtklp-1.0f1
-rw-r--r--net-print/gtklp/gtklp-1.0f.ebuild48
4 files changed, 57 insertions, 11 deletions
diff --git a/net-print/gtklp/ChangeLog b/net-print/gtklp/ChangeLog
index 63012db70f8c..6d4261dd3362 100644
--- a/net-print/gtklp/ChangeLog
+++ b/net-print/gtklp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/gtklp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.17 2005/06/06 22:44:36 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.18 2005/07/10 15:52:23 lanius Exp $
+
+*gtklp-1.0f (10 Jul 2005)
+
+ 10 Jul 2005; Heinrich Wendel <lanius@gentoo.org> +gtklp-1.0f.ebuild:
+ version bump
*gtklp-1.0d (06 Jun 2005)
diff --git a/net-print/gtklp/Manifest b/net-print/gtklp/Manifest
index d751e568b4a6..a63376bd079f 100644
--- a/net-print/gtklp/Manifest
+++ b/net-print/gtklp/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 391b24dce74b6c892078b223bb01ba28 gtklp-1.0f.ebuild 1230
MD5 a2ae6998c0151f0d999fa667e3218c72 gtklp-0.9p.ebuild 1153
MD5 391b24dce74b6c892078b223bb01ba28 gtklp-1.0d.ebuild 1230
MD5 a80908cd0f720ccd8ac6c9e518d008e6 ChangeLog 2448
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 3021ef15adb0dbab1dc9262e26c71139 files/digest-gtklp-0.9p 66
MD5 4fd76e2df308a5c25d23efac634af30a files/digest-gtklp-1.0d 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCpNHeevY57Fted3ERAip8AKDMJWHRQQLyAVmQ8T3saouoMQyXFACgyXTL
-qmMMlnRHUBagEAbkr3TovTY=
-=MYmk
------END PGP SIGNATURE-----
+MD5 d89a62afde24d6a31984edc709573046 files/digest-gtklp-1.0f 67
diff --git a/net-print/gtklp/files/digest-gtklp-1.0f b/net-print/gtklp/files/digest-gtklp-1.0f
new file mode 100644
index 000000000000..b9f90bec265b
--- /dev/null
+++ b/net-print/gtklp/files/digest-gtklp-1.0f
@@ -0,0 +1 @@
+MD5 ce01d390f94b00b899ffa0c69596602f gtklp-1.0f.src.tar.gz 1328732
diff --git a/net-print/gtklp/gtklp-1.0f.ebuild b/net-print/gtklp/gtklp-1.0f.ebuild
new file mode 100644
index 000000000000..c04580518b6d
--- /dev/null
+++ b/net-print/gtklp/gtklp-1.0f.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-1.0f.ebuild,v 1.1 2005/07/10 15:52:24 lanius Exp $
+
+inherit libtool
+
+DESCRIPTION="A GUI for cupsd"
+SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz"
+HOMEPAGE="http://gtklp.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+LICENSE="GPL-2"
+IUSE="gtk2 nls ssl"
+
+DEPEND="!gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ >=net-print/cups-1.1.7
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ # nls fix
+ sed -i -e "s:#include <cups/language.h>:#ifndef _LOCALE_H\n#define _LOCALE_H\n#endif\n#include <cups/language.h>:" libgtklp/libgtklp.h
+
+ # package uses gtk2 by default, has switch to request gtk1
+ use gtk2 \
+ && myconf="${myconf} --disable-gtk1" \
+ || myconf="${myconf} --enable-gtk1"
+
+ econf \
+ ${myconf} \
+ $(use_enable nls) \
+ $(use_enable ssl) \
+ || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS || die
+
+ use nls || rm -rf ${D}/usr/share/locale
+}