summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-04 13:00:40 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-04 13:00:40 +0000
commitb344442b8ccb24d2934cea362ec2f0cc9cd83a1e (patch)
tree3e6e3bc2de7bfc4d14f3da83591e1aecfa12dccc /net-proxy/http-replicator
parentVersion bump to 1.4.0_pre1. (diff)
downloadgentoo-2-b344442b8ccb24d2934cea362ec2f0cc9cd83a1e.tar.gz
gentoo-2-b344442b8ccb24d2934cea362ec2f0cc9cd83a1e.tar.bz2
gentoo-2-b344442b8ccb24d2934cea362ec2f0cc9cd83a1e.zip
Version bump to 4.0_alpha2.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy/http-replicator')
-rw-r--r--net-proxy/http-replicator/ChangeLog10
-rw-r--r--net-proxy/http-replicator/http-replicator-4.0_alpha2.ebuild51
2 files changed, 59 insertions, 2 deletions
diff --git a/net-proxy/http-replicator/ChangeLog b/net-proxy/http-replicator/ChangeLog
index af3f66571c44..0ca6ea8b3e80 100644
--- a/net-proxy/http-replicator/ChangeLog
+++ b/net-proxy/http-replicator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/http-replicator
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.36 2012/09/30 18:52:35 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/ChangeLog,v 1.37 2013/03/04 13:00:40 tomwij Exp $
+
+*http-replicator-4.0_alpha2 (04 Mar 2013)
+
+ 04 Mar 2013; Tom Wijsman <TomWij@gentoo.org>
+ +http-replicator-4.0_alpha2.ebuild:
+ Version bump to 4.0_alpha2.
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> http-replicator-3.0-r2.ebuild:
Move to ~alpha
diff --git a/net-proxy/http-replicator/http-replicator-4.0_alpha2.ebuild b/net-proxy/http-replicator/http-replicator-4.0_alpha2.ebuild
new file mode 100644
index 000000000000..24d8c421ac33
--- /dev/null
+++ b/net-proxy/http-replicator/http-replicator-4.0_alpha2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/http-replicator/http-replicator-4.0_alpha2.ebuild,v 1.1 2013/03/04 13:00:40 tomwij Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2:2.7:2.7" # not 2.6 bug #33907, not 3.0 bug #411083
+inherit eutils python
+
+MY_P="${PN}_${PV/_/}"
+
+DESCRIPTION="Proxy cache for Gentoo packages"
+HOMEPAGE="http://sourceforge.net/projects/${PN}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+src_install(){
+ # Daemon and repcacheman into /usr/bin
+ exeinto /usr/bin
+ doexe http-replicator
+ newexe "${FILESDIR}/http-replicator-3.0-callrepcacheman-0.1" repcacheman
+ newexe "${FILESDIR}/http-replicator-3.0-repcacheman-0.44-r2" repcacheman.py
+
+ # init.d scripts
+ newinitd "${FILESDIR}/http-replicator-3.0.init" http-replicator
+ newconfd "${FILESDIR}/http-replicator-3.0.conf" http-replicator
+
+ # not 2.6 bug #33907, not 3.0 bug #411083
+ python_convert_shebangs -r 2.7 "${ED}"
+
+ # Docs
+ dodoc README.user README.devel RELNOTES
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Before starting http-replicator, please follow the next few steps:"
+ einfo "- modify /etc/conf.d/http-replicator if required"
+ einfo "- run /usr/bin/repcacheman to set up the cache"
+ einfo "- add http_proxy=\"http://serveraddress:8080\" to make.conf on"
+ einfo " the server as well as on the client machines"
+ einfo "- make sure GENTOO_MIRRORS in /etc/make.conf starts with several"
+ einfo " good http mirrors"
+ einfo
+ einfo "For more information please refer to the following forum thread:"
+ einfo " http://forums.gentoo.org/viewtopic-t-173226.html"
+ einfo
+}