summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:16:44 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:16:44 +0000
commitc11419c38fba245ce4c12248ae8f0d2d21052f2e (patch)
treeee2b93d7a72971d4cf117b7cfac8a5693566ea31 /net-wireless/gnome-bluetooth
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-c11419c38fba245ce4c12248ae8f0d2d21052f2e.tar.gz
gentoo-2-c11419c38fba245ce4c12248ae8f0d2d21052f2e.tar.bz2
gentoo-2-c11419c38fba245ce4c12248ae8f0d2d21052f2e.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/ChangeLog7
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.8.0.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/net-wireless/gnome-bluetooth/ChangeLog b/net-wireless/gnome-bluetooth/ChangeLog
index 2232a76586df..c3152464d4d2 100644
--- a/net-wireless/gnome-bluetooth/ChangeLog
+++ b/net-wireless/gnome-bluetooth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/gnome-bluetooth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.124 2013/02/02 23:09:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.125 2013/03/28 22:16:44 pacho Exp $
+
+*gnome-bluetooth-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gnome-bluetooth-3.8.0.ebuild:
+ Version bump for Gnome 3.8
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> gnome-bluetooth-3.6.1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.8.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.8.0.ebuild
new file mode 100644
index 000000000000..59d4aec7319b
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.8.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-3.8.0.ebuild,v 1.1 2013/03/28 22:16:44 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2 multilib udev user
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/11" # subslot = libgnome-bluetooth soname version
+IUSE="+introspection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND=">=dev-libs/glib-2.29.90:2
+ >=x11-libs/gtk+-2.91.3:3[introspection?]
+ >=x11-libs/libnotify-0.7:=
+ virtual/udev
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd
+ x11-themes/gnome-icon-theme-symbolic"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
+ rm -v lib/bluetooth-client-glue.{c,h} || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # FIXME: Add geoclue support
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ --enable-documentation
+ --disable-maintainer-mode
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-static
+ ITSTOOL=$(type -P true)"
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version sys-auth/consolekit[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}