summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-12-18 02:12:10 +0000
committerChristian Heim <phreak@gentoo.org>2006-12-18 02:12:10 +0000
commit36d9c66f50252d031a64e6ed0d9f2d3d99bed049 (patch)
tree94f82446a82fd2fe438f26e18b7a1c6d08b6ef3f /net-wireless/ipw2100
parentAdding a patch for ipw2100 to work with kernel >=2.6.19. Thanks to Johan Hovo... (diff)
downloadgentoo-2-36d9c66f50252d031a64e6ed0d9f2d3d99bed049.tar.gz
gentoo-2-36d9c66f50252d031a64e6ed0d9f2d3d99bed049.tar.bz2
gentoo-2-36d9c66f50252d031a64e6ed0d9f2d3d99bed049.zip
Also including Johan Hovold's patch for kernel-2.6.19 and the removed config.h (thanks again to Johan Hovold <jhovold at gmail.com>, this time #157796).
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'net-wireless/ipw2100')
-rw-r--r--net-wireless/ipw2100/ChangeLog8
-rw-r--r--net-wireless/ipw2100/files/ipw2100-1.2.1-config.h.patch12
-rw-r--r--net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild7
3 files changed, 23 insertions, 4 deletions
diff --git a/net-wireless/ipw2100/ChangeLog b/net-wireless/ipw2100/ChangeLog
index e1161e630374..b8775f979f5a 100644
--- a/net-wireless/ipw2100/ChangeLog
+++ b/net-wireless/ipw2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/ipw2100
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw2100/ChangeLog,v 1.103 2006/12/18 01:52:46 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw2100/ChangeLog,v 1.104 2006/12/18 02:12:10 phreak Exp $
+
+ 18 Dec 2006; Christian Heim <phreak@gentoo.org>
+ +files/ipw2100-1.2.1-config.h.patch, ipw2100-1.2.1-r2.ebuild:
+ Also including Johan Hovold's patch for kernel-2.6.19 and the removed
+ config.h (thanks again to Johan Hovold <jhovold at gmail.com>, this time
+ #157796).
*ipw2100-1.2.1-r2 (18 Dec 2006)
diff --git a/net-wireless/ipw2100/files/ipw2100-1.2.1-config.h.patch b/net-wireless/ipw2100/files/ipw2100-1.2.1-config.h.patch
new file mode 100644
index 000000000000..8b65bc8c7902
--- /dev/null
+++ b/net-wireless/ipw2100/files/ipw2100-1.2.1-config.h.patch
@@ -0,0 +1,12 @@
+--- ipw2100-1.2.1.orig/ipw2100.c 2006-12-11 15:12:53.000000000 +1100
++++ ipw2100-1.2.1/ipw2100.c 2006-12-11 15:14:35.000000000 +1100
+@@ -134,7 +134,9 @@
+ */
+
+ #include <linux/compiler.h>
++#ifndef AUTOCONF_INCLUDED
+ #include <linux/config.h>
++#endif
+ #include <linux/errno.h>
+ #include <linux/if_arp.h>
+ #include <linux/in6.h>
diff --git a/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild b/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild
index d52648d90c2b..bfbb82d6f52d 100644
--- a/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild
+++ b/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild,v 1.1 2006/12/18 01:52:46 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw2100/ipw2100-1.2.1-r2.ebuild,v 1.2 2006/12/18 02:12:10 phreak Exp $
inherit eutils linux-mod
@@ -41,7 +41,7 @@ pkg_setup() {
die "${P} does not support building against kernel 2.4.x"
fi
- if [[ ! -f ${ROOT}/lib/modules/${KV_FULL}/net/ieee80211/ieee80211.${KV_OBJ} ]]; then
+ if [[ ! -f "${ROOT}/lib/modules/${KV_FULL}/net/ieee80211/ieee80211.${KV_OBJ}" ]]; then
eerror
eerror "Looks like you forgot to remerge net-wireless/ieee80211 after"
eerror "upgrading your kernel."
@@ -64,6 +64,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-cflags.patch"
epatch "${FILESDIR}/${P}-double-parentheses.patch"
epatch "${FILESDIR}/${P}-essid.patch"
+ epatch "${FILESDIR}/${P}-config.h.patch"
use debug && debug="y"
sed -i -e "s:^\(CONFIG_IPW2100_DEBUG\)=.*:\1=$debug:" "${S}"/Makefile
@@ -87,7 +88,7 @@ src_install() {
pkg_postinst() {
linux-mod_pkg_postinst
- if [ -f ${ROOT}/lib/modules/${KV_FULL}/net/${PN}.ko ]; then
+ if [ -f "${ROOT}/lib/modules/${KV_FULL}/net/${PN}.ko" ]; then
einfo
einfo "Modules from an earlier installation detected. You will need to manually"
einfo "remove those modules by running the following commands:"