summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-04-17 21:21:19 +0000
committerRick Farina <zerochaos@gentoo.org>2014-04-17 21:21:19 +0000
commit6517bdb2322ec31a55be83c1c9d83216a192aa69 (patch)
tree9bec23a6888014dba3be514104a3e309002926a0 /net-wireless/lorcon
parentFix LICENSE, add mirror and bindist restrictions, update SRC_URI, bug 470778. (diff)
downloadgentoo-2-6517bdb2322ec31a55be83c1c9d83216a192aa69.tar.gz
gentoo-2-6517bdb2322ec31a55be83c1c9d83216a192aa69.tar.bz2
gentoo-2-6517bdb2322ec31a55be83c1c9d83216a192aa69.zip
migrate to distutils-r1 thanks to much help from mgorny
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/lorcon')
-rw-r--r--net-wireless/lorcon/ChangeLog11
-rw-r--r--net-wireless/lorcon/lorcon-0.0_p20130212-r1.ebuild (renamed from net-wireless/lorcon/lorcon-0.0_p20130212.ebuild)41
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild41
3 files changed, 45 insertions, 48 deletions
diff --git a/net-wireless/lorcon/ChangeLog b/net-wireless/lorcon/ChangeLog
index f60d8a15c692..4061da7603ce 100644
--- a/net-wireless/lorcon/ChangeLog
+++ b/net-wireless/lorcon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/lorcon
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/ChangeLog,v 1.4 2013/05/28 05:05:22 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/ChangeLog,v 1.5 2014/04/17 21:21:19 zerochaos Exp $
+
+*lorcon-0.0_p20130212-r1 (17 Apr 2014)
+
+ 17 Apr 2014; Rick Farina <zerochaos@gentoo.org>
+ +lorcon-0.0_p20130212-r1.ebuild, -lorcon-0.0_p20130212.ebuild,
+ lorcon-9999.ebuild:
+ migrate to distutils-r1 thanks to much help from mgorny
28 May 2013; Rick Farina <zerochaos@gentoo.org> lorcon-0.0_p20130212.ebuild,
lorcon-9999.ebuild:
diff --git a/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild b/net-wireless/lorcon/lorcon-0.0_p20130212-r1.ebuild
index d43e2e80ecef..e099b314ffee 100644
--- a/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild
+++ b/net-wireless/lorcon/lorcon-0.0_p20130212-r1.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-0.0_p20130212.ebuild,v 1.2 2013/05/28 05:05:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-0.0_p20130212-r1.ebuild,v 1.1 2014/04/17 21:21:19 zerochaos Exp $
EAPI=5
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby19"
RUBY_OPTIONAL=yes
-inherit distutils ruby-ng
+inherit distutils-r1 ruby-ng
DESCRIPTION="A generic library for injecting 802.11 frames"
HOMEPAGE="http://802.11ninja.net/lorcon"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://code.google.com/p/lorcon/"
- inherit git-2
+ inherit git-r3
KEYWORDS=""
else
SRC_URI="http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
@@ -30,23 +29,22 @@ SLOT="0"
IUSE="python ruby"
DEPEND="ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
dev-libs/libnl
net-libs/libpcap"
RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
S="${WORKDIR}"/${P}
pkg_setup() {
- if use python; then
- python_pkg_setup;
- DISTUTILS_SETUP_FILES=("${S}/pylorcon2|setup.py")
- fi
use ruby && ruby-ng_pkg_setup
}
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
cp -R "${S}/" "${WORKDIR}/all"
fi
default_src_unpack
@@ -58,7 +56,7 @@ src_prepare() {
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
- use python && distutils_src_prepare
+ use python && distutils-r1_src_prepare
use ruby && ruby-ng_src_prepare
}
@@ -71,27 +69,24 @@ src_compile() {
use ruby && ruby-ng_src_compile
if use python; then
LDFLAGS+=" -L${S}/.libs/"
- distutils_src_compile
+ cd pylorcon2 || die
+ distutils-r1_src_compile
fi
}
src_install() {
emake DESTDIR="${ED}" install
- use python && distutils_src_install
use ruby && ruby-ng_src_install
+ if use python; then
+ cd pylorcon2 || die
+ distutils-r1_src_install
+ fi
}
src_test() {
:
}
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
-
each_ruby_compile() {
sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/${P}/ruby-lorcon -L${WORKDIR}/${P}/.libs#" ruby-lorcon/extconf.rb
"${RUBY}" -C ruby-lorcon extconf.rb || die
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
index def1016af7b2..508a9e788517 100644
--- a/net-wireless/lorcon/lorcon-9999.ebuild
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-9999.ebuild,v 1.3 2013/05/28 05:05:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-9999.ebuild,v 1.4 2014/04/17 21:21:19 zerochaos Exp $
EAPI=5
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby19"
RUBY_OPTIONAL=yes
-inherit distutils ruby-ng
+inherit distutils-r1 ruby-ng
DESCRIPTION="A generic library for injecting 802.11 frames"
HOMEPAGE="http://802.11ninja.net/lorcon"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://code.google.com/p/lorcon/"
- inherit git-2
+ inherit git-r3
KEYWORDS=""
else
SRC_URI="http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
@@ -30,23 +29,22 @@ SLOT="0"
IUSE="python ruby"
DEPEND="ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
dev-libs/libnl
net-libs/libpcap"
RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
S="${WORKDIR}"/${P}
pkg_setup() {
- if use python; then
- python_pkg_setup;
- DISTUTILS_SETUP_FILES=("${S}/pylorcon2|setup.py")
- fi
use ruby && ruby-ng_pkg_setup
}
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
+ git-r3_src_unpack
cp -R "${S}/" "${WORKDIR}/all"
fi
default_src_unpack
@@ -58,7 +56,7 @@ src_prepare() {
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
- use python && distutils_src_prepare
+ use python && distutils-r1_src_prepare
use ruby && ruby-ng_src_prepare
}
@@ -71,27 +69,24 @@ src_compile() {
use ruby && ruby-ng_src_compile
if use python; then
LDFLAGS+=" -L${S}/.libs/"
- distutils_src_compile
+ cd pylorcon2 || die
+ distutils-r1_src_compile
fi
}
src_install() {
emake DESTDIR="${ED}" install
- use python && distutils_src_install
use ruby && ruby-ng_src_install
+ if use python; then
+ cd pylorcon2 || die
+ distutils-r1_src_install
+ fi
}
src_test() {
:
}
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
-
each_ruby_compile() {
sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/${P}/ruby-lorcon -L${WORKDIR}/${P}/.libs#" ruby-lorcon/extconf.rb
"${RUBY}" -C ruby-lorcon extconf.rb || die