summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2007-02-10 07:30:31 +0000
committerStephen Klimaszewski <steev@gentoo.org>2007-02-10 07:30:31 +0000
commit89c24117fa0897f747fdf8a098d55bbdb927eaaf (patch)
tree6c4c6c872fd01137c07fa62fae6a7ab9d50ccf0c /net-wireless/rt2570/rt2570-20070209.ebuild
parentMoving the linux_mod-pkg_setup around, Fixing #166152 (thanks to Jan). (diff)
downloadgentoo-2-89c24117fa0897f747fdf8a098d55bbdb927eaaf.tar.gz
gentoo-2-89c24117fa0897f747fdf8a098d55bbdb927eaaf.tar.bz2
gentoo-2-89c24117fa0897f747fdf8a098d55bbdb927eaaf.zip
Add a cvs snapshot ebuild for rt2570. Closes bug #162128. Thanks to Paulo da Silva for reporting and making the snapshot.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-wireless/rt2570/rt2570-20070209.ebuild')
-rw-r--r--net-wireless/rt2570/rt2570-20070209.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-wireless/rt2570/rt2570-20070209.ebuild b/net-wireless/rt2570/rt2570-20070209.ebuild
new file mode 100644
index 000000000000..ab12646bc717
--- /dev/null
+++ b/net-wireless/rt2570/rt2570-20070209.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2570/rt2570-20070209.ebuild,v 1.1 2007/02/10 07:30:31 steev Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Driver for the RaLink RT2570 USB wireless chipset"
+HOMEPAGE="http://rt2x00.serialmonkey.com"
+SRC_URI="http://gentoo.zerodev.it/snapshots/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+DEPEND="net-wireless/wireless-tools"
+
+pkg_setup() {
+ MODULE_NAMES="rt2570(net:${S}/Module)"
+ CONFIG_CHECK="NET_RADIO BROKEN_ON_SMP"
+ BROKEN_ON_SMP_ERROR="SMP Processors and Kernels are currently not supported"
+ linux-mod_pkg_setup
+ if use_m
+ then BUILD_PARAMS="-C ${KV_DIR} M=${S}/Module"
+ BUILD_TARGETS="modules"
+ else die "please use a kernel >=2.6.6"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc Module/TESTING Module/iwpriv_usage.txt THANKS FAQ CHANGELOG
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog "to set up the card you can use:"
+ elog "- iwconfig from wireless-tools"
+ elog "- iwpriv, like described in \"/usr/share/doc/${PF}/iwpriv_usage.txt.gz"\"
+}