summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-12 03:14:24 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-12 03:14:24 +0000
commit10405eac20fb14ef1df214e4a0c88c7014f52fea (patch)
treef2144def98bb3b123e024f2186ab0481d9a7b4a6 /net-wireless
parenthad an issue where /var/lib/misc/oui.txt was unclaimed, now it is (diff)
downloadgentoo-2-10405eac20fb14ef1df214e4a0c88c7014f52fea.tar.gz
gentoo-2-10405eac20fb14ef1df214e4a0c88c7014f52fea.tar.bz2
gentoo-2-10405eac20fb14ef1df214e4a0c88c7014f52fea.zip
initial commit of lorcon
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/lorcon/ChangeLog9
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild95
-rw-r--r--net-wireless/lorcon/metadata.xml11
3 files changed, 115 insertions, 0 deletions
diff --git a/net-wireless/lorcon/ChangeLog b/net-wireless/lorcon/ChangeLog
new file mode 100644
index 000000000000..204f6156e331
--- /dev/null
+++ b/net-wireless/lorcon/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-wireless/lorcon
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/ChangeLog,v 1.1 2013/04/12 03:14:24 zerochaos Exp $
+
+*lorcon-9999 (12 Apr 2013)
+
+ 12 Apr 2013; Rick Farina <zerochaos@gentoo.org> +lorcon-9999.ebuild,
+ +metadata.xml:
+ initial commit of lorcon
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
new file mode 100644
index 000000000000..05b359b87795
--- /dev/null
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/lorcon/lorcon-9999.ebuild,v 1.1 2013/04/12 03:14:24 zerochaos Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+USE_RUBY="ruby18 ruby19"
+RUBY_OPTIONAL=yes
+
+inherit git-2 distutils ruby-ng
+
+DESCRIPTION="A generic library for injecting 802.11 frames"
+HOMEPAGE="http://802.11ninja.net/lorcon"
+EGIT_REPO_URI="https://code.google.com/p/lorcon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="python ruby"
+
+DEPEND="ruby? ( $(ruby_implementations_depend) )"
+RDEPEND="${DEPEND}
+ dev-libs/libnl"
+
+S="${WORKDIR}"/all
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup;
+ DISTUTILS_SETUP_FILES=("${S}/pylorcon2|setup.py")
+ fi
+ use ruby && ruby-ng_pkg_setup
+}
+
+src_unpack() {
+ git-2_src_unpack
+ use ruby && ruby-ng_src_unpack
+}
+
+src_prepare() {
+ use python && distutils_src_prepare
+ sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
+ sed -i 's#find_library("orcon2", "lorcon_list_drivers", "lorcon2/lorcon.h") and ##' ruby-lorcon/extconf.rb
+ sed -i "s#-I/usr/include/lorcon2#-I${WORKDIR}/all#" ruby-lorcon/extconf.rb
+ sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' ruby-lorcon/Lorcon2.h
+ use ruby && ruby-ng_src_prepare
+}
+
+src_configure() {
+ default_src_configure
+ use ruby && ruby-ng_src_configure
+}
+
+src_compile() {
+ default_src_compile
+ if use python; then
+ LDFLAGS+=" -L${S}/.libs/"
+ distutils_src_compile
+ fi
+ use ruby && ruby-ng_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ use python && distutils_src_install
+ use ruby && ruby-ng_src_install
+}
+
+src_test() {
+ :
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
+
+each_ruby_configure() {
+ ${RUBY} -C "ruby-lorcon" extconf.rb
+ sed -i "s#-L\.#-L. -L${WORKDIR}/all/.libs -lorcon2 #g" ruby-lorcon/Makefile
+}
+
+each_ruby_compile() {
+ emake -C ruby-lorcon
+}
+
+each_ruby_install() {
+ DESTDIR="${ED}" emake -C ruby-lorcon install
+}
diff --git a/net-wireless/lorcon/metadata.xml b/net-wireless/lorcon/metadata.xml
new file mode 100644
index 000000000000..5fcbf8e1851a
--- /dev/null
+++ b/net-wireless/lorcon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+