summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-09 16:02:50 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-09 16:02:50 +0000
commit729fce81676bb44c7cadac460cb0d4292c060f6b (patch)
tree7ddce26a73dcce633c11585211d8e3f8891bf40a /net-www/htdig
parent*** empty log message *** (diff)
downloadgentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.tar.gz
gentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.tar.bz2
gentoo-2-729fce81676bb44c7cadac460cb0d4292c060f6b.zip
*** empty log message ***
Diffstat (limited to 'net-www/htdig')
-rw-r--r--net-www/htdig/htdig-3.1.5.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-www/htdig/htdig-3.1.5.ebuild b/net-www/htdig/htdig-3.1.5.ebuild
index fd845e3afe04..faafe9789f46 100644
--- a/net-www/htdig/htdig-3.1.5.ebuild
+++ b/net-www/htdig/htdig-3.1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.5.ebuild,v 1.1 2000/10/06 22:03:49 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.5.ebuild,v 1.2 2000/10/09 16:02:49 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,14 +11,16 @@ HOMEPAGE="http://www.htdig.org"
src_unpack() {
unpack ${A}
- cp ${FILESDIR}/CONFIG ${S}
+ cp ${FILESDIR}/CONFIG.in ${S}
}
src_compile() {
cd ${S}
- try ./configure --prefix=/usr --host=${CHOST}
- cp ${FILESDIR}/CONFIG ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --with-cgi-bin-dir=/usr/local/httpd/cgi-bin \
+ --with-image-dir=/usr/local/httpd/images/htdig \
+ --with-search-dir=/usr/local/httpd/htdocs/htdig
try make
}
@@ -26,7 +28,10 @@ src_compile() {
src_install () {
cd ${S}
- try make DESTDIR=${D} install
+ try make DESTDIR=${D} CGIBIN_DIR=${D}/usr/local/httpd/cgi-bin \
+ SEARCH_DIR=${D}/usr/local/httpd/htdocs/htdig \
+ IMAGE_DIR=${D}/usr/local/httpd/htdocs/images/htdig \
+ exec_prefix=${D}/usr install
}