summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-01-22 04:12:47 +0000
committerChristian Parpart <trapni@gentoo.org>2005-01-22 04:12:47 +0000
commit81c9d1d5a427361d56e94433a2e4cc1daa19934d (patch)
tree89fb1795ced86c981a95e53b0b5be133e4bd0db5 /net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild
parentAdded license needed by net-dialup/intel536ep. (diff)
downloadgentoo-2-81c9d1d5a427361d56e94433a2e4cc1daa19934d.tar.gz
gentoo-2-81c9d1d5a427361d56e94433a2e4cc1daa19934d.tar.bz2
gentoo-2-81c9d1d5a427361d56e94433a2e4cc1daa19934d.zip
apache herd package refresh
(Portage version: 2.0.51-r14)
Diffstat (limited to 'net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild')
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild
new file mode 100644
index 000000000000..8a5c081d67a4
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-2.8.1.ebuild,v 1.1 2005/01/22 04:12:46 trapni Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
+DEPEND="dev-db/mysql"
+RDEPEND=""
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+SLOT="0"
+
+BASE_CONFIG_PVR="2.8.1"
+
+# Dual Apache
+DOCFILES="README"
+
+# Apache 2.0
+APXS2_S="${S}"
+APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE2_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE2_MOD_DEFINE="AUTH_MYSQL"
+
+# Apache 1.x
+APXS1_S="${S}"
+APXS1_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE1_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE1_MOD_DEFINE="AUTH_MYSQL"
+
+need_apache