summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-10-24 04:21:38 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-10-24 04:21:38 +0000
commit6c33dd561119a7623ebf5618144fe1145bd36048 (patch)
tree4a3d7244ac7b23f834067c5a2489a308362df502 /net-www/mod_gzip
parentStable x86 last one for tonight I think (diff)
downloadgentoo-2-6c33dd561119a7623ebf5618144fe1145bd36048.tar.gz
gentoo-2-6c33dd561119a7623ebf5618144fe1145bd36048.tar.bz2
gentoo-2-6c33dd561119a7623ebf5618144fe1145bd36048.zip
New revision that uses the eclass to build rather then upstreams broken Makefile. Also added documentation. Removed unused files.
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'net-www/mod_gzip')
-rw-r--r--net-www/mod_gzip/ChangeLog10
-rw-r--r--net-www/mod_gzip/files/digest-mod_gzip-1.3.26.1a-r33
-rw-r--r--net-www/mod_gzip/mod_gzip-1.3.26.1a-r3.ebuild36
3 files changed, 48 insertions, 1 deletions
diff --git a/net-www/mod_gzip/ChangeLog b/net-www/mod_gzip/ChangeLog
index dddad55d53b4..ec89faa4db9e 100644
--- a/net-www/mod_gzip/ChangeLog
+++ b/net-www/mod_gzip/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-www/mod_gzip
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_gzip/ChangeLog,v 1.31 2006/06/04 19:45:40 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_gzip/ChangeLog,v 1.32 2006/10/24 04:21:38 vericgar Exp $
+
+*mod_gzip-1.3.26.1a-r3 (24 Oct 2006)
+
+ 24 Oct 2006; Michael Stewart <vericgar@gentoo.org> -files/changes.txt,
+ -files/commands.txt, -files/mod_gzip.conf, -files/mod_gzip.conf-new,
+ +mod_gzip-1.3.26.1a-r3.ebuild:
+ New revision that uses the eclass to build rather then upstreams broken
+ Makefile. Also added documentation. Removed unused files.
04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
-mod_gzip-1.3.19.1a-r1.ebuild, -mod_gzip-1.3.26.1a.ebuild,
diff --git a/net-www/mod_gzip/files/digest-mod_gzip-1.3.26.1a-r3 b/net-www/mod_gzip/files/digest-mod_gzip-1.3.26.1a-r3
new file mode 100644
index 000000000000..0a8d90e6ad89
--- /dev/null
+++ b/net-www/mod_gzip/files/digest-mod_gzip-1.3.26.1a-r3
@@ -0,0 +1,3 @@
+MD5 080ccc5d789ed5efa0c0a7625e4fa02d mod_gzip-1.3.26.1a.tgz 137394
+RMD160 60499f6189c9b4e25657b27c272caf6243b64262 mod_gzip-1.3.26.1a.tgz 137394
+SHA256 db9dd1c621f86d19145a2d7e9ad255f54fad067924744926478f9e72e8deaef5 mod_gzip-1.3.26.1a.tgz 137394
diff --git a/net-www/mod_gzip/mod_gzip-1.3.26.1a-r3.ebuild b/net-www/mod_gzip/mod_gzip-1.3.26.1a-r3.ebuild
new file mode 100644
index 000000000000..c35bebabee02
--- /dev/null
+++ b/net-www/mod_gzip/mod_gzip-1.3.26.1a-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_gzip/mod_gzip-1.3.26.1a-r3.ebuild,v 1.1 2006/10/24 04:21:38 vericgar Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Apache module which acts as an Internet Content Accelerator"
+HOMEPAGE="http://sourceforge.net/projects/mod-gzip/"
+SRC_URI="mirror://sourceforge/mod-gzip/mod_gzip-${PV}.tgz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="Apache-1.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-libs/zlib-1.1.4"
+RDEPEND="${DEPEND}"
+
+APXS1_ARGS="-c mod_gzip.c mod_gzip_debug.c mod_gzip_compress.c"
+APACHE1_MOD_CONF="10_${PN}"
+APACHE1_MOD_DEFINE="GZIP"
+
+need_apache1
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/mod-gzip-debug.patch || die
+}
+
+src_install() {
+ apache1_src_install
+ dodoc ChangeLog
+ dohtml -r docs/manual/
+}
+