summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-06-04 20:10:28 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-06-04 20:10:28 +0000
commit3b262edf3590c58c84c16ccc46044f9a83ec9de5 (patch)
tree4fded16f0a8d2beb080d72de93039ae8a36c0952 /net-www/moinmoin
parentAdded eject to base system layout (diff)
downloadgentoo-2-3b262edf3590c58c84c16ccc46044f9a83ec9de5.tar.gz
gentoo-2-3b262edf3590c58c84c16ccc46044f9a83ec9de5.tar.bz2
gentoo-2-3b262edf3590c58c84c16ccc46044f9a83ec9de5.zip
New package.
Diffstat (limited to 'net-www/moinmoin')
-rw-r--r--net-www/moinmoin/ChangeLog10
-rw-r--r--net-www/moinmoin/files/digest-moinmoin-1.01
-rw-r--r--net-www/moinmoin/moinmoin-1.0.ebuild44
3 files changed, 55 insertions, 0 deletions
diff --git a/net-www/moinmoin/ChangeLog b/net-www/moinmoin/ChangeLog
new file mode 100644
index 000000000000..dca6e0087d6e
--- /dev/null
+++ b/net-www/moinmoin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/moinmoin
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/moinmoin/ChangeLog,v 1.1 2002/06/04 20:10:28 g2boojum Exp $
+
+*moinmoin-1.0 (4 June 2002)
+
+ 4 June 2002; Grant Goodyear <g2boojum@gentoo.org> moinmoin-1.0.ebuild :
+
+ New package.
+
diff --git a/net-www/moinmoin/files/digest-moinmoin-1.0 b/net-www/moinmoin/files/digest-moinmoin-1.0
new file mode 100644
index 000000000000..a2a6185fa4ad
--- /dev/null
+++ b/net-www/moinmoin/files/digest-moinmoin-1.0
@@ -0,0 +1 @@
+MD5 0eb137c592261bbb051208ef8f4ffd7d moin-1.0.tar.gz 361909
diff --git a/net-www/moinmoin/moinmoin-1.0.ebuild b/net-www/moinmoin/moinmoin-1.0.ebuild
new file mode 100644
index 000000000000..1690526297a1
--- /dev/null
+++ b/net-www/moinmoin/moinmoin-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/moinmoin/moinmoin-1.0.ebuild,v 1.1 2002/06/04 20:10:28 g2boojum Exp $
+
+PN0="moin"
+S=${WORKDIR}/${PN0}-${PV}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+
+DESCRIPTION="Python WikiClone"
+
+SRC_URI="http://download.sourceforge.net/${PN0}/${PN0}-${PV}.tar.gz"
+HOMEPAGE="http://moin.sourceforge.net"
+
+DEPEND=">=dev-lang/python-2.2"
+
+RDEPEND="net-www/apache"
+
+src_compile() {
+ python setup.py build || die "python build failed"
+}
+
+src_install () {
+ python setup.py install --root=${D} --prefix=/usr install || die "python install failed"
+ dodir ${HTTPD_ROOT}/${P}
+ dosym ${HTTPD_ROOT}/${P} ${HTTPD_ROOT}/${PN}
+ cd ${D}/usr/share/moin
+ cp -r data htdocs/* ${D}/${HTTPD_ROOT}/${P}
+ cp cgi-bin/* ${D}/${HTTPD_ROOT}/${P}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_USER} ${P}
+ cd ${D}/${HTTPD_ROOT}/${P}
+ chmod a+x moin.cgi
+ mv moin_config.py moin_config.py.orig
+ sed -e "s/\/wiki/\/moinmoin/" moin_config.py.orig \
+ > moin_config.py
+ rm moin_config.py.orig
+}
+
+pkg_postinst() {
+ einfo
+ einfo "MoinMoin requires that cgi be turned on in ${HTTPD_ROOT}/${P}."
+ einfo
+}