summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-04-12 20:30:54 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-04-12 20:30:54 +0000
commit7c8df73cfdb0dbbada4e5192c3a466a1c81ffc1b (patch)
treeaa7d1927e94a8cf2cd6ac3fa37ad8c51c3bf48b2 /net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild
parentfix two bugs with a simple trivial feature (diff)
downloadgentoo-2-7c8df73cfdb0dbbada4e5192c3a466a1c81ffc1b.tar.gz
gentoo-2-7c8df73cfdb0dbbada4e5192c3a466a1c81ffc1b.tar.bz2
gentoo-2-7c8df73cfdb0dbbada4e5192c3a466a1c81ffc1b.zip
Added lateset version and small gcc4 patch from bug #124685.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild')
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild
new file mode 100644
index 000000000000..a55236199de0
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.25.ebuild,v 1.1 2006/04/12 20:30:54 josejx Exp $
+
+inherit eutils multilib nsplugins
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gecko-sdk gtk"
+
+DEPEND=">=media-video/mplayer-1.0_pre5
+ gecko-sdk? ( net-libs/gecko-sdk )
+ !gecko-sdk? ( || ( >=www-client/mozilla-1.6 www-client/mozilla-firefox ) )
+ || ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc4.patch
+}
+
+src_compile() {
+ local myconf
+
+ if use gecko-sdk; then
+ myconf="${myconf} --with-gecko-sdk=/usr/$(get_libdir)/gecko-sdk"
+ fi
+
+ # We force gtk2 now because moz only compiles against gtk2
+ if use gtk; then
+ myconf="${myconf} --enable-gtk2"
+ else
+ ewarn "For playback controls, you must enable gtk support."
+ myconf="${myconf} --enable-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ PLUGINS="gmp rm qt wmp"
+
+ for plugin in ${PLUGINS}; do
+ ### Install the plugin
+ exeinto /opt/netscape/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.so"
+ ### Install the xpt
+ insinto /opt/netscape/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.xpt"
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}