summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-03-05 15:36:04 +0000
committerAron Griffis <agriffis@gentoo.org>2003-03-05 15:36:04 +0000
commit9b20479b42faf5b4051d1089f0f19008ec57e1fe (patch)
tree1ec03035f4cc26f6da51446dc19bc0a78aa2ca29 /net-www/w3m
parentstable on alpha (diff)
downloadgentoo-2-9b20479b42faf5b4051d1089f0f19008ec57e1fe.tar.gz
gentoo-2-9b20479b42faf5b4051d1089f0f19008ec57e1fe.tar.bz2
gentoo-2-9b20479b42faf5b4051d1089f0f19008ec57e1fe.zip
update to 0.4, fix bugs 16868 and 8879
Diffstat (limited to 'net-www/w3m')
-rw-r--r--net-www/w3m/ChangeLog9
-rw-r--r--net-www/w3m/files/digest-w3m-0.41
-rw-r--r--net-www/w3m/w3m-0.4.ebuild153
3 files changed, 162 insertions, 1 deletions
diff --git a/net-www/w3m/ChangeLog b/net-www/w3m/ChangeLog
index 4df21c79305d..c19be6a3acf8 100644
--- a/net-www/w3m/ChangeLog
+++ b/net-www/w3m/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/w3m
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.17 2003/02/17 14:22:12 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.18 2003/03/05 15:36:04 agriffis Exp $
+
+*w3m-0.4 (05 Mar 2003)
+
+ 05 Mar 2003; Aron Griffis <agriffis@gentoo.org> w3m-0.4.ebuild:
+ Updated to 0.4. Fixed bug #16868 by updating the configuration monologue and
+ adding a sanity check at the end. Fixed bug #8879 by adding dep on
+ media-libs/compface, thanks to Lim Swee Tat for the heads-up.
*w3m-0.3.2.2 (17 Feb 2003)
diff --git a/net-www/w3m/files/digest-w3m-0.4 b/net-www/w3m/files/digest-w3m-0.4
new file mode 100644
index 000000000000..7c45a16add42
--- /dev/null
+++ b/net-www/w3m/files/digest-w3m-0.4
@@ -0,0 +1 @@
+MD5 15d530510918c8271528386450aa4acd w3m-0.4.tar.gz 1256357
diff --git a/net-www/w3m/w3m-0.4.ebuild b/net-www/w3m/w3m-0.4.ebuild
new file mode 100644
index 000000000000..678f20d6c62a
--- /dev/null
+++ b/net-www/w3m/w3m-0.4.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.4.ebuild,v 1.1 2003/03/05 15:36:04 agriffis Exp $
+
+IUSE="gpm cjk imlib ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+SRC_URI="mirror://sourceforge/w3m/${P}.tar.gz"
+HOMEPAGE="http://w3m.sourceforge.net/"
+
+SLOT="0"
+LICENSE="w3m"
+KEYWORDS="x86 ~sparc ~alpha ~ppc"
+
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ media-libs/compface
+ imlib? ( >=media-libs/imlib-1.9.8 )
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+PROVIDE="virtual/textbrowser"
+
+src_compile() {
+ # It seems to be hard to configure this program in any reasonable
+ # way.
+ (
+ # Which directory do you want to put the binary?
+ echo /usr/bin
+ # Which directory do you want to put the support binary files?
+ echo /usr/lib/w3m
+ # Which directory do you want to use local cgi?
+ echo /usr/lib/w3m/cgi-bin
+ # Which directory do you want to put the helpfile?
+ echo /usr/share/w3m
+ # Which directory do you want to put the manfile?
+ echo /usr/share/man
+ # Which directory do you want to put the system wide w3m
+ # configuration file?
+ echo /etc/w3m
+ # Which language do you prefer?
+ # 1 - Japanese (charset ISO-2022-JP, EUC-JP, Shift_JIS)
+ # 2 - English (charset US_ASCII, ISO-8859-1, etc.)
+ if use cjk &>/dev/null; then
+ echo 1
+ # What is your Kanji display
+ echo E
+ # Use 2-byte character for table border, etc
+ echo n
+ else
+ echo 2
+ fi
+ # Use Lynx-like key binding as default [n]?
+ echo n
+ # Let's do some configurations. Choose config option among the list.
+ #
+ # 1 - Baby model (no color, no menu, no mouse, no cookie, no SSL)
+ # 2 - Little model (color, menu, no mouse, no cookie, no SSL)
+ # 3 - Mouse model (color, menu, mouse, no cookie, no SSL)
+ # 4 - Cookie model (color, menu, mouse, cookie, no SSL)
+ # 5 - Monster model (with everything; you need openSSL library)
+ # 6 - Customize
+ #
+ # Which?
+ echo 6
+ # Do you want color ESC sequence for Kterm/pxvt
+ echo y
+ # Use mouse (requires xterm/kterm/gpm/sysmouse)
+ use gpm &>/dev/null && echo y
+ # Use popup menu
+ echo y
+ # Use cookie
+ echo y
+ # Do you want SSL verification support?
+ # (Your SSL library must be version 0.8 or later)
+ if use ssl &>/dev/null; then
+ echo y
+ # (ssl) SSL verification support (SSL library >= version 0.8) [n]?
+ echo n
+ # (ssl) Digest Auth support [y]?
+ echo y
+ else
+ echo n
+ fi
+ # Inline image support?
+ if use imlib &>/dev/null; then
+ echo y
+ # X11 inline image support (you need Imlib, Imlib2 or
+ # GdkPixbuf library) [y]?
+ echo y
+ # Linux Framebuffer inline image support (you need Imlib2
+ # or GdkPixbuf) [n]?
+ echo y
+ # setuid w3mimgdisplay to open /dev/fb0? [y]?
+ echo n
+ else
+ echo n
+ fi
+ # ANSI color escape sequences support [n]?
+ echo y
+ # Use Migemo (Roma-ji search; Please see
+ # http://migemo.namazu.org/) [n]?
+ echo n
+ # External URI loader support [y]?
+ echo y
+ # Use w3mmail.cgi [y]?
+ echo y
+ # NNTP support [y]?
+ echo n
+ # Gopher support [y]?
+ echo n
+ # Use alarm support code [y]?
+ echo y
+ # Use mark operation [y]?
+ echo y
+ # X-Face support (you need uncompface) [n]?
+ echo y
+ # Input your favorite editor program.
+ echo /usr/bin/nano
+ # Input your favorite external browser program.
+ echo /usr/bin/mozilla
+ # Input your favorite C-compiler.
+ echo gcc
+ # Input your favorite C flags.
+ printf "%s\n" "$CFLAGS"
+ # Which terminal library do you want to use? (type "none" if you
+ # do not need one)
+ echo
+ #printf "%s\n" "-lncurses"
+ # Input additional LD flags other than listed above, if any:
+ # (default: -lncurses) :
+ echo
+ ) | ./configure || die "configure failed"
+
+ # Test to make sure the above configuration was sane
+ grep -q "dcc='gcc'" config.param || \
+ die "configure out of sync; ebuild needs an update"
+
+ # binary executables come prebuilt for 80386!
+ # clean it up and be sure to remake for ANY arch
+ cd ${S}/gc
+ make clean
+ cd -
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc doc/* README*
+ doman doc/w3m.1
+}