summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-07-11 19:44:00 +0000
committerStuart Herbert <stuart@gentoo.org>2004-07-11 19:44:00 +0000
commit6c92f9b1fe66de3e030768300f2bca378357ac38 (patch)
tree636bf7fade72cda44984894bbb405d31d5281ff4 /net-www/webapp-config/webapp-config-1.10-r5.ebuild
parentversionbump (Manifest recommit) (diff)
downloadgentoo-2-6c92f9b1fe66de3e030768300f2bca378357ac38.tar.gz
gentoo-2-6c92f9b1fe66de3e030768300f2bca378357ac38.tar.bz2
gentoo-2-6c92f9b1fe66de3e030768300f2bca378357ac38.zip
Version bump; config file fix + more vars for hook scripts
Diffstat (limited to 'net-www/webapp-config/webapp-config-1.10-r5.ebuild')
-rw-r--r--net-www/webapp-config/webapp-config-1.10-r5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-www/webapp-config/webapp-config-1.10-r5.ebuild b/net-www/webapp-config/webapp-config-1.10-r5.ebuild
new file mode 100644
index 000000000000..daac9f2b258a
--- /dev/null
+++ b/net-www/webapp-config/webapp-config-1.10-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/webapp-config/webapp-config-1.10-r5.ebuild,v 1.1 2004/07/11 19:44:00 stuart Exp $
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~stuart/${PN}/${PN}-${PVR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/grep
+ sys-apps/findutils
+ sys-apps/sed
+ sys-apps/gawk
+ sys-apps/coreutils
+ app-shells/bash
+ app-portage/gentoolkit"
+
+S=${WORKDIR}/${PF}
+
+src_compile() {
+ # do nothing
+ true
+}
+
+src_install() {
+ dosbin sbin/webapp-config
+ dodir /usr/lib/webapp-config
+ cp -R lib/* ${D}/usr/lib/webapp-config/
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ dodir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt README.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ sleep 5
+}