summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-02 14:06:33 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-02 14:06:33 +0000
commit14927f76ff76bb9d2995d53cf99f8371f7d76978 (patch)
treeff2f34cccfe49a7c8ca658f90d2653518caea365 /net-www
parentVersion bumped. (diff)
downloadgentoo-2-14927f76ff76bb9d2995d53cf99f8371f7d76978.tar.gz
gentoo-2-14927f76ff76bb9d2995d53cf99f8371f7d76978.tar.bz2
gentoo-2-14927f76ff76bb9d2995d53cf99f8371f7d76978.zip
Version bumped.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog7
-rw-r--r--net-www/apache/Manifest4
-rw-r--r--net-www/apache/apache-1.3.29.ebuild255
-rw-r--r--net-www/apache/files/digest-apache-1.3.293
4 files changed, 266 insertions, 3 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index d22e3a2fc926..0f9b9a825da9 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/apache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.79 2003/10/31 20:39:58 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.80 2003/11/02 14:06:26 mholzer Exp $
+
+*apache-1.3.29 (02 Nov 2003)
+
+ 02 Nov 2003; Martin Holzer <mholzer@gentoo.org> apache-1.3.29.ebuild:
+ Version bumped.
31 Oct 2003; Jason Wever <weeve@gentoo.org> apache-2.0.48.ebuild:
Marked stable on sparc in accordance with GLSA 200310-04.
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index ed8e38609b3b..9689522a1eea 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,4 +1,4 @@
-MD5 76b5cec1e631b09fcbd75fb36ad88fe9 ChangeLog 15899
+MD5 08ae2a21cc7922cb4767b69bf70f8788 ChangeLog 16022
MD5 03c997dee35fcd0c56d77294ef557ab0 apache-2.0.47.ebuild 11434
MD5 246f3d374581e892615e2e5c8cb59e2a apache-1.3.27-r3.ebuild 7884
MD5 d4bfc120696457a6084e949b99d045ac apache-1.3.27-r4.ebuild 8913
@@ -7,7 +7,7 @@ MD5 c8e565da1b91536d92e4e2a3001400a5 apache-1.3.28.ebuild 9135
MD5 09fa626c00f029bdfb266b1e5d16193e apache-1.3.28-r1.ebuild 7905
MD5 235d2261cabdf2fbf72bee4b0ddd519f apache-2.0.47-r1.ebuild 10711
MD5 bd80c41f0d8d92374c3712c4cac4d2ff metadata.xml 503
-MD5 25e61bdcbae823f0e124dd4357384cf1 apache-1.3.29.ebuild 7905
+MD5 18cb8436ab1b04381c78c9f9b5b6fc48 apache-1.3.29.ebuild 7503
MD5 bfe3bdf50a9328e0e90060cbbaf4b624 apache-2.0.48.ebuild 11153
MD5 f2c60b199c12729b25716ed451a24e38 files/apache-2.0.44-gentoo.diff 4895
MD5 9dc40e1918a2d30a578ebf1653f7182c files/apache-2.0.45-gentoo.diff 5448
diff --git a/net-www/apache/apache-1.3.29.ebuild b/net-www/apache/apache-1.3.29.ebuild
new file mode 100644
index 000000000000..fc083d3c0bdb
--- /dev/null
+++ b/net-www/apache/apache-1.3.29.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.29.ebuild,v 1.1 2003/11/02 14:06:27 mholzer Exp $
+
+#IUSE="ipv6 pam"
+IUSE="pam"
+
+mod_ssl_ver=2.8.16
+
+S=${WORKDIR}/${PN}_${PV}
+DESCRIPTION="The Apache Web Server"
+HOMEPAGE="http://www.apache.org http://www.modssl.org"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~amd64"
+SRC_URI="http://httpd.apache.org/dist/httpd/apache_${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ftp://ftp.modssl.org/source/mod_ssl-${mod_ssl_ver}-${PV}.tar.gz"
+# ipv6? http://motoyuki.bsdclub.org/data/IPv6/apache-${PV}-mod_ssl-${mod_ssl_ver}-v6-20021004.diff.gz"
+# The mod_ssl archive is only for providing the EAPI patch in here.
+# You should install the net-www/mod_ssl package for the actual DSO.
+
+DEPEND="dev-lang/perl <sys-libs/db-4.1
+ >=dev-libs/mm-1.1.3
+ >=sys-libs/gdbm-1.8
+ >=dev-libs/expat-1.95.2"
+LICENSE="Apache-1.1"
+SLOT="1"
+
+#Standard location for Gentoo Linux
+DATADIR="/var/www/localhost"
+
+src_unpack() {
+ local myssl
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff || die
+
+ #Obsolete 'head -1' and 'tail -1' calls.
+ perl -pi -e 's|tail -1|tail -n 1|;' \
+ src/Configure src/helpers/getuid.sh
+ perl -pi -e 's|head -1|head -n 1|;' \
+ src/Configure src/helpers/buildinfo.sh src/helpers/fmn.sh
+
+ #Make apachectl read /etc/conf.d/apache
+ epatch ${FILESDIR}/apache-1.3.27-apachectl.patch || die
+
+ sed -i "s:/usr/local/bin/perl5:/usr/bin/perl:" \
+ htdocs/manual/search/manual-index.cgi
+
+ # setup eapi...
+ myssl=${WORKDIR}/mod_ssl-${mod_ssl_ver}-${PV}
+ cp ${myssl}/pkg.eapi/*.h src/include
+ cp ${myssl}/pkg.eapi/*.c src/ap
+ epatch ${myssl}/pkg.eapi/eapi.patch || die "eapi"
+
+ # set a reasonable MM_CORE_PATH location..
+ sed -i 's:logs/mm:/var/cache/apache-mm/mm:' \
+ src/include/httpd.h
+
+# # thanks drey@rt.mipt.ru for these two ...
+# if use ipv6; then
+# zcat ${DISTDIR}/apache-${PV}-mod_ssl-${mod_ssl_ver}-v6-20021004.diff.gz | patch -p0 || die
+# fi
+
+ if use pam; then
+ epatch ${FILESDIR}/suexec_pam_gentoo.patch || die
+ fi
+
+ # Detect db4 correctly
+ epatch ${FILESDIR}/apache-1.3.27_db4_gentoo.patch || die
+}
+
+src_compile() {
+ local myconf mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+# use ipv6 && myconf="--enable-rule=INET6"
+
+ select_modules_config || die "determining modules"
+
+ #-DBUFFERED_LOGS
+ OPTIM="${mycflags} -DHARD_SERVER_LIMIT=${HARD_SERVER_LIMIT:=512} \
+ -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
+ LIBS="-lgdbm -lpthread" \
+ EAPI_MM=SYSTEM \
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib/apache \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/apache/conf \
+ --datadir=${DATADIR} \
+ --cgidir=${DATADIR}/cgi-bin \
+ --iconsdir=${DATADIR}/icons \
+ --htdocsdir=${DATADIR}/htdocs \
+ --manualdir=/usr/share/doc/${PF}/manual \
+ --includedir=/usr/include/apache \
+ --localstatedir=/var \
+ --runtimedir=/var/run \
+ --logfiledir=/var/log/apache \
+ --proxycachedir=/var/cache/apache \
+ --serverroot=/etc/apache \
+ \
+ --target=apache \
+ --server-uid=apache \
+ --server-gid=apache \
+ --enable-rule=EAPI \
+ --enable-rule=SHARED_CHAIN \
+ --with-perl=/usr/bin/perl \
+ \
+ ${MY_BUILTINS} \
+ \
+ --enable-suexec \
+ --suexec-uidmin=1000 \
+ --suexec-gidmin=100 \
+ --suexec-caller=apache \
+ --suexec-userdir=public_html \
+ --suexec-docroot=/home \
+ --suexec-safepath="/bin:/usr/bin" \
+ --suexec-logfile=/var/log/apache/suexec_log \
+ \
+ ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ local myfile
+
+ GID=`getent group apache | cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ make install-quiet root=${D} || die
+ dodoc ABOUT_APACHE Announcement INSTALL* LICENSE* README* WARNING* \
+ ${FILESDIR}/robots.txt
+
+ #protect the suexec binary
+ fowners root.${GID} /usr/sbin/suexec
+ fperms 4710 /usr/sbin/suexec
+
+ # nice support scripts..
+ for myfile in apacheaddmod apachedelmod \
+ apachelogserverstatus apachesplitlogfile
+ do
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/$myfile
+ done
+
+ # setup links in /etc/apache..
+ cd ${D}/etc/apache
+ ln -sf ../../usr/lib/apache modules
+ # apxs needs this to pickup the right lib for install..
+ ln -sf ../../usr/lib lib
+ ln -sf ../../var/log/apache logs
+ ln -sf ../../usr/lib/apache-extramodules extramodules
+
+ # drop in a convenient link to the manual
+ dosym /usr/share/doc/${PF}/manual ${DATADIR}/htdocs/manual
+
+ # deprecated config files, empty dirs..
+ rm -f ${D}/etc/apache/conf/apache.conf.default
+ rm -f ${D}/etc/apache/conf/access.conf*
+ rm -f ${D}/etc/apache/conf/srm.conf*
+
+ # now the config files..
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/conf/commonapache.conf
+ doins ${FILESDIR}/conf/apache.conf
+
+ # Added by Jason Wever <weeve@gentoo.org>
+ # A little sedfu to fix bug #7172 for sparc64s
+ if [ ${ARCH} = "sparc" ]
+ then
+ sed -i -e '15a\AcceptMutex fcntl' \
+ ${D}/etc/apache/conf/apache.conf
+ fi
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/conf/VirtualHomePages.conf
+ doins ${FILESDIR}/conf/DynamicVhosts.conf
+ doins ${FILESDIR}/conf/Vhosts.conf
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/apache.rc6 apache
+ insinto /etc/conf.d ; newins ${FILESDIR}/apache.confd apache
+ insinto /etc/apache ; doins ${FILESDIR}/apache-builtin-mods
+
+ if use pam; then
+ insinto /etc/pam.d ; newins ${FILESDIR}/suexec.pam suexec
+ fi
+
+ #empty dirs
+ dodir /var/cache/apache ; touch ${D}/var/cache/apache/.keep
+ dodir /var/cache/apache-mm ; touch ${D}/var/cache/apache-mm/.keep
+ dodir /usr/lib/apache-extramodules ; touch ${D}/usr/lib/apache-extramodules/.keep
+ dodir /etc/apache/conf/addon-modules ; touch ${D}/etc/apache/conf/addon-modules/.keep
+ dodir /var/log/apache ; touch ${D}/var/log/apache/.keep
+}
+
+pkg_postinst() {
+ # these are in baselayout now; it will not hurt to leave them here though
+ # moved to pkg_postinst by jnelson, moved to pkg_preinst by lostlogic
+ getent group apache >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ groupadd -g 81 apache || die "problem adding group apache"
+ fi
+
+ # usermod returns 2 on user-exists-but-no-flags-given
+ #usermod apache &>/dev/null
+ #if [ $? != 2 ]; then
+ getent passwd apache >/dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ useradd -u 81 -g apache -s /bin/false -d /var/www/localhost -c "apache" apache
+ assert "problem adding user apache"
+ fi
+
+ einfo
+ einfo "Please remember to update your config files in /etc/apache"
+ einfo "as --datadir has been changed to ${DATADIR}!"
+ einfo
+}
+
+parse_modules_config() {
+ local filename=$1
+ local name=""
+ local dso=""
+ local disable=""
+ [ -f ${filename} ] || return 1
+ einfo "Using ${filename} for builtins."
+ for i in `cat $filename | sed "s/^#.*//"` ; do
+ if [ $i == "-" ] ; then
+ disable="true"
+ elif [ -z "$name" ] && [ ! -z "`echo $i | grep "mod_"`" ] ; then
+ name=`echo $i | sed "s/mod_//"`
+ elif [ "$disable" ] && ( [ $i == "static" ] || [ $i == "shared" ] ) ; then
+ MY_BUILTINS="${MY_BUILTINS} --disable-module=$name"
+ name="" ; disable=""
+ elif [ $i == "static" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-module=$name --disable-shared=$name"
+ name="" ; disable=""
+ elif [ $i == "shared" ] ; then
+ MY_BUILTINS="${MY_BUILTINS} --enable-module=$name --enable-shared=$name"
+ name="" ; disable=""
+ fi
+ done
+}
+
+select_modules_config() {
+ parse_modules_config /etc/apache/apache-builtin-mods || \
+ parse_modules_config ${FILESDIR}/apache-builtin-mods || \
+ return 1
+}
diff --git a/net-www/apache/files/digest-apache-1.3.29 b/net-www/apache/files/digest-apache-1.3.29
new file mode 100644
index 000000000000..a5423284e321
--- /dev/null
+++ b/net-www/apache/files/digest-apache-1.3.29
@@ -0,0 +1,3 @@
+MD5 e97fe9bf51dc2c9c233d53f63b1347e3 apache_1.3.29.tar.gz 2435809
+MD5 2faa15ad074ab273af41496a1afa527f apache-1.3.29-gentoo.diff.bz2 6862
+MD5 4f6c580ffa07d33e8584406132b98e86 mod_ssl-2.8.16-1.3.29.tar.gz 754325