summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-16 22:08:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-16 22:08:53 +0000
commitabc602eb610438056e5776ad67e0b6e5570f7883 (patch)
tree0d39a39bd8e37c1b712ffe0822f5b1b0617f2240 /net-www
parentcleanup (diff)
downloadgentoo-2-abc602eb610438056e5776ad67e0b6e5570f7883.tar.gz
gentoo-2-abc602eb610438056e5776ad67e0b6e5570f7883.tar.bz2
gentoo-2-abc602eb610438056e5776ad67e0b6e5570f7883.zip
added webapps-apache.eclass. Closes #33622
Diffstat (limited to 'net-www')
-rw-r--r--net-www/htdig/ChangeLog5
-rw-r--r--net-www/htdig/Manifest4
-rw-r--r--net-www/htdig/htdig-3.1.6-r4.ebuild30
3 files changed, 28 insertions, 11 deletions
diff --git a/net-www/htdig/ChangeLog b/net-www/htdig/ChangeLog
index 2d304cc0e606..b7043c624afc 100644
--- a/net-www/htdig/ChangeLog
+++ b/net-www/htdig/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/htdig
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.16 2003/11/16 18:14:33 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/ChangeLog,v 1.17 2003/11/16 22:08:47 mholzer Exp $
+
+ 16 Nov 2003; Martin Holzer <mholzer@gentoo.org> htdig-3.1.6-r4.ebuild:
+ added webapps-apache.eclass. Closes #33622
16 Nov 2003; Brad House <brad_mssw@gentoo.org> htdig-3.1.6-r4.ebuild:
mark stable on amd64
diff --git a/net-www/htdig/Manifest b/net-www/htdig/Manifest
index 3befb76907d6..b8215d98332e 100644
--- a/net-www/htdig/Manifest
+++ b/net-www/htdig/Manifest
@@ -1,4 +1,4 @@
-MD5 68249da16fbe9bce0c86e78ab79ab8bf ChangeLog 3494
-MD5 adaa69419b57bc38c541756a7d5be123 htdig-3.1.6-r4.ebuild 1478
+MD5 8901f6626c7cfaa043aee6bdb0ef6ed3 ChangeLog 3611
+MD5 0f2b83d668932550b656fa1a5b5ed3f3 htdig-3.1.6-r4.ebuild 1767
MD5 8863dac1d260decb47f31d1a3fe422e2 files/CONFIG.in 2012
MD5 10558a7c02e5ea20fdfe325e6186fc9d files/digest-htdig-3.1.6-r4 64
diff --git a/net-www/htdig/htdig-3.1.6-r4.ebuild b/net-www/htdig/htdig-3.1.6-r4.ebuild
index e1edf5a5ab72..f2d95018d6b1 100644
--- a/net-www/htdig/htdig-3.1.6-r4.ebuild
+++ b/net-www/htdig/htdig-3.1.6-r4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.6-r4.ebuild,v 1.12 2003/11/16 18:14:33 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.6-r4.ebuild,v 1.13 2003/11/16 22:08:47 mholzer Exp $
+
+inherit webapp-apache
S=${WORKDIR}/${P}
DESCRIPTION="HTTP/HTML indexing and searching system"
@@ -15,16 +17,28 @@ DEPEND=">=sys-libs/zlib-1.1.3
export CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+webapp-detect || NO_WEBSERVER=1
+
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
src_compile() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
cd ${S}
./configure \
--prefix=/usr \
--with-config-dir=/etc/${PN} \
- --with-cgi-bin-dir=/home/httpd/cgi-bin \
+ --with-cgi-bin-dir=${HTTPD_CGIBIN} \
--with-common-dir=/usr/share/${PN} \
--with-database-dir=/var/${PN}/db \
- --with-image-dir=/home/httpd/htdocs/${PN} \
+ --with-image-dir=${destdir} \
--with-default-config-file=/etc/${PN}/${PN}.conf \
|| die
@@ -33,15 +47,17 @@ src_compile() {
}
src_install () {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
make \
DESTDIR=${D} \
CONFIG_DIR=${D}/etc/${PN} \
- SEARCH_DIR=${D}/home/httpd/htdocs/${PN} \
- CGIBIN_DIR=${D}/home/httpd/cgi-bin \
+ SEARCH_DIR=${D}/${destdir} \
+ CGIBIN_DIR=${D}/${HTTPD_CGIBIN} \
COMMON_DIR=${D}/usr/share/${PN} \
DATABASE_DIR=${D}/var/${PN}/db \
- IMAGE_DIR=${D}/home/httpd/htdocs/${PN} \
+ IMAGE_DIR=${D}/${destdir} \
DEFAULT_CONFIG_FILE=${D}/etc/${PN}/${PN}.conf \
exec_prefix=${D}/usr \
install || die
@@ -57,6 +73,4 @@ src_install () {
touch ${D}/var/htdig/db/word2root.db
touch ${D}/var/htdig/db/root2word.db
-
}
-