summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-06-25 11:52:56 +0000
committerChuck Short <zul@gentoo.org>2004-06-25 11:52:56 +0000
commite439c43fec2d51f4e19b33b31e8e8077c9abfe44 (patch)
tree0496300fb903a73e06a88d1e82ac31d1b33e7c07 /net-www
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-e439c43fec2d51f4e19b33b31e8e8077c9abfe44.tar.gz
gentoo-2-e439c43fec2d51f4e19b33b31e8e8077c9abfe44.tar.bz2
gentoo-2-e439c43fec2d51f4e19b33b31e8e8077c9abfe44.zip
Replaced berkdb detection. closes #54932.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog6
-rw-r--r--net-www/apache/apache-2.0.49-r3.ebuild36
2 files changed, 24 insertions, 18 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 2a02d9928d49..9e151616a26f 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/apache
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.210 2004/06/25 00:48:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.211 2004/06/25 11:52:56 zul Exp $
+
+ 25 Jun 2004; Chuck Short <zul@gentoo.org> apache-2.0.49-r3.ebuild:
+ Replaced version berkdb detection with something that is much more smarter.
+ Shamelessly taken from the php.eclass. Closes #54932.
21 Jun 2004; Danny van Dyk <kugelfang@gentoo.org> apache-1.3.31-r2.ebuild:
Marked stable on amd64.
diff --git a/net-www/apache/apache-2.0.49-r3.ebuild b/net-www/apache/apache-2.0.49-r3.ebuild
index 2d8af07b8ac0..0b13e3bd14cf 100644
--- a/net-www/apache/apache-2.0.49-r3.ebuild
+++ b/net-www/apache/apache-2.0.49-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2004 Gentoo Foundation.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r3.ebuild,v 1.15 2004/06/25 00:48:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r3.ebuild,v 1.16 2004/06/25 11:52:56 zul Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -9,8 +9,7 @@ S="${WORKDIR}/httpd-${PV}"
DESCRIPTION="Apache Web Server, Version 2.0.x"
HOMEPAGE="http://www.apache.org/"
SRC_URI="http://www.apache.org/dist/httpd/httpd-${PV}.tar.gz
- mirror://gentoo/apache-patches-${PATCH_LEVEL}.tar.bz2
- http://dev.gentoo.org/~zul/apache/apache-patches-${PATCH_LEVEL}.tar.bz2"
+ mirror://gentoo/apache-patches-${PATCH_LEVEL}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="2"
@@ -33,21 +32,8 @@ DEPEND="dev-util/yacc
apache_setup_vars() {
# Sets the USERDIR to default.
USERDIR="public_html"
-
- if use berkdb; then
- db_major=`grep DB_VERSION_MAJOR /usr/include/db.h | cut -f3`
- db_minor=`grep DB_VERSION_MINOR /usr/include/db.h | cut -f3`
- if [ $db_minor -gt 0 ];
- then
- db_version="db4"
- else
- db_version=`echo "db$db_major.$db_minor"`
- fi
- append-ldflags -l`echo "$db_version"`
- fi
einfo "DATADIR is set to: ${DATADIR}"
einfo "USERDIR is set to: $USERDIR"
- einfo "DB verison detected is $db_version"
}
set_filter_flags () {
@@ -79,6 +65,22 @@ src_unpack() {
epatch ${WORKDIR}/01_ssl_verify_client.patch || die
fi
+ if use berkdb; then
+ einfo "Enabling berkdb."
+ if has_version '=sys-libs/db-4*'; then
+ einfo "Enabling db4"
+ myconf="${myconf} --with-dbm=db4 --with-berkely-db=/usr"
+ elif has_version '=sys-libs/db-3*'; then
+ einfo "Enabling db3"
+ myconf="${myconf} --with-dbm=db3 --with-berkely-db=/usr"
+ elif has_version '=sys-libs/db-2'; then
+ einfo "Enabling db2"
+ myconf="${myconf} --with-dbm=db2 --with-berkely-db=/usr"
+ fi
+ else
+ echo "Disabling berkdb"
+ fi
+
#avoid utf-8 charset problems
export LC_CTYPE=C