summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 22:10:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 22:10:38 +0000
commit37c3e0b5c5e2a338136d42f0399a06a264cb8b96 (patch)
tree796e0edfa73616abc05a1e6d5a5500046af7b498 /net-zope/zctextindex
parentInitial addition. (diff)
downloadgentoo-2-37c3e0b5c5e2a338136d42f0399a06a264cb8b96.tar.gz
gentoo-2-37c3e0b5c5e2a338136d42f0399a06a264cb8b96.tar.bz2
gentoo-2-37c3e0b5c5e2a338136d42f0399a06a264cb8b96.zip
Initial addition.
(Portage version: 2.2_rc83_p18/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zctextindex')
-rw-r--r--net-zope/zctextindex/ChangeLog10
-rw-r--r--net-zope/zctextindex/metadata.xml5
-rw-r--r--net-zope/zctextindex/zctextindex-2.13.0.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/net-zope/zctextindex/ChangeLog b/net-zope/zctextindex/ChangeLog
new file mode 100644
index 000000000000..7890df0cb03f
--- /dev/null
+++ b/net-zope/zctextindex/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zctextindex
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zctextindex/ChangeLog,v 1.1 2010/09/17 22:10:38 arfrever Exp $
+
+*zctextindex-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zctextindex-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zctextindex/metadata.xml b/net-zope/zctextindex/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/zctextindex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/zctextindex/zctextindex-2.13.0.ebuild b/net-zope/zctextindex/zctextindex-2.13.0.ebuild
new file mode 100644
index 000000000000..c2b99b51f880
--- /dev/null
+++ b/net-zope/zctextindex/zctextindex-2.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zctextindex/zctextindex-2.13.0.ebuild,v 1.1 2010/09/17 22:10:38 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.ZCTextIndex"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Full text indexing for ZCatalog / Zope 2."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ZCTextIndex"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/persistence
+ net-zope/transaction
+ net-zope/zexceptions
+ net-zope/zodb
+ >=net-zope/zope-2.12
+ net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt src/Products/ZCTextIndex/README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # http://svn.zope.org/?rev=114425&view=rev
+ sed -e "/packages=/a namespace_packages=['Products']," -i setup.py || die "sed failed"
+}