summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-04 20:25:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-04 20:25:39 +0000
commitf596c0b5c31bea0330f2726e5134a660a5c59dbf (patch)
tree269753046f557d45b16bf69523d3c43799edd6cf /net-zope
parentDelete older ebuild. (diff)
downloadgentoo-2-f596c0b5c31bea0330f2726e5134a660a5c59dbf.tar.gz
gentoo-2-f596c0b5c31bea0330f2726e5134a660a5c59dbf.tar.bz2
gentoo-2-f596c0b5c31bea0330f2726e5134a660a5c59dbf.zip
Version bump.
(Portage version: 2.2.0_alpha30_p48/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zcatalog/ChangeLog8
-rw-r--r--net-zope/zcatalog/zcatalog-2.13.13.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-zope/zcatalog/ChangeLog b/net-zope/zcatalog/ChangeLog
index 83073a145b32..d96275be9d6e 100644
--- a/net-zope/zcatalog/ChangeLog
+++ b/net-zope/zcatalog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zcatalog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.8 2011/05/02 22:01:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/ChangeLog,v 1.9 2011/05/04 20:25:39 arfrever Exp $
+
+*zcatalog-2.13.13 (04 May 2011)
+
+ 04 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zcatalog-2.13.13.ebuild:
+ Version bump.
*zcatalog-2.13.12 (02 May 2011)
diff --git a/net-zope/zcatalog/zcatalog-2.13.13.ebuild b/net-zope/zcatalog/zcatalog-2.13.13.ebuild
new file mode 100644
index 000000000000..ac3570990b3e
--- /dev/null
+++ b/net-zope/zcatalog/zcatalog-2.13.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcatalog/zcatalog-2.13.13.ebuild,v 1.1 2011/05/04 20:25:39 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
+
+inherit distutils
+
+MY_PN="Products.ZCatalog"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope 2's indexing and search solution."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ZCatalog"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/restrictedpython
+ net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/documenttemplate
+ net-zope/extensionclass
+ net-zope/missing
+ net-zope/persistence
+ net-zope/record
+ net-zope/zexceptions
+ net-zope/zodb
+ >=net-zope/zope-2.12
+ net-zope/zope-dottedname
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-testing"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+PDEPEND="net-zope/zctextindex"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="Products/PluginIndexes ${MY_PN/.//}"