summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-02 15:22:55 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-02 15:22:55 +0000
commit566fda7201be682d2505c804fcb230b450a9da00 (patch)
tree95ab98de046ed02ccb077ed032f5dfa5e7bd25d2 /sci-astronomy/wcstools/wcstools-3.6.2.ebuild
parentVersion bump because of bug #106560. (diff)
downloadgentoo-2-566fda7201be682d2505c804fcb230b450a9da00.tar.gz
gentoo-2-566fda7201be682d2505c804fcb230b450a9da00.tar.bz2
gentoo-2-566fda7201be682d2505c804fcb230b450a9da00.zip
Initial import.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-astronomy/wcstools/wcstools-3.6.2.ebuild')
-rw-r--r--sci-astronomy/wcstools/wcstools-3.6.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-astronomy/wcstools/wcstools-3.6.2.ebuild b/sci-astronomy/wcstools/wcstools-3.6.2.ebuild
new file mode 100644
index 000000000000..48533a0195bc
--- /dev/null
+++ b/sci-astronomy/wcstools/wcstools-3.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcstools/wcstools-3.6.2.ebuild,v 1.1 2005/10/02 15:22:55 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Astronomy Library to handle World Coordinate System for FITS images"
+HOMEPAGE="http://tdc-www.harvard.edu/software/wcstools"
+SRC_URI="http://tdc-www.harvard.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin wcstools bin/* || die
+ dolib.a libwcs/*.a || die
+ dodoc Readme Programs Versions || die
+ doman Man/man1/* || die
+ insinto /usr/include/wcstools
+ doins libwcs/*.h || die
+}