summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 04:27:39 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 04:27:39 +0000
commitd8e0b70cb09d688aa89575aed965155d58698a1e (patch)
tree948d75bd45d4748708ab4538de36e8a51b85cedb /sci-astronomy/xephem/xephem-3.6.2.ebuild
parentPatch to fix compiling with gcc-3.4.x. (Manifest recommit) (diff)
downloadgentoo-2-d8e0b70cb09d688aa89575aed965155d58698a1e.tar.gz
gentoo-2-d8e0b70cb09d688aa89575aed965155d58698a1e.tar.bz2
gentoo-2-d8e0b70cb09d688aa89575aed965155d58698a1e.zip
Moved from app-sci/xephem to sci-astronomy/xephem.
Diffstat (limited to 'sci-astronomy/xephem/xephem-3.6.2.ebuild')
-rw-r--r--sci-astronomy/xephem/xephem-3.6.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-astronomy/xephem/xephem-3.6.2.ebuild b/sci-astronomy/xephem/xephem-3.6.2.ebuild
new file mode 100644
index 000000000000..200fe1ec915f
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-3.6.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.6.2.ebuild,v 1.1 2004/12/24 04:27:39 ribosome Exp $
+
+DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
+SRC_URI="http://www.clearskyinstitute.com/xephem/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://www.clearskyinstitute.com/xephem"
+KEYWORDS="x86 amd64 ppc"
+IUSE=""
+SLOT="0"
+LICENSE="as-is"
+DEPEND="x11-libs/openmotif"
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${P}.tar.gz ] ; then
+ die "Please download ${P}.tar.gz from ${HOMEPAGE} and move it to ${DISTDIR}"
+ fi
+}
+
+src_compile() {
+
+ cd libastro
+ sed -e "s:CFLAGS=.*:CFLAGS=${CFLAGS} -ffast-math -Wall:" \
+ -i Makefile
+ emake || die
+
+ for i in libip liblilxml libjpegd; do
+ echo "going into ${i}"
+ cd ${S}/${i}
+ sed -e "s:CFLAGS=.*:CFLAGS=${CFLAGS} -I../libastro -ffast-math -Wall:" \
+ -i Makefile
+ emake || die
+ done
+
+ cd ../GUI/xephem
+ xmkmf
+ sed -e "s:CDEBUGFLAGS = .*:CDEBUGFLAGS = ${CFLAGS} -fno-strength-reduce:" \
+ -i Makefile
+ emake || die
+
+}
+
+src_install() {
+
+ into /usr
+ dobin ${S}/GUI/xephem/xephem
+ for i in auxil catalogs fifos fits help help/png; do
+ insinto /opt/xephem/${i}
+ doins ${S}/GUI/xephem/${i}/*
+ done
+
+ cat > ${S}/XEphem <<EOT
+XEphem.ShareDir: /opt/xephem
+EOT
+ insinto /usr/lib/X11/app-defaults/
+ doins ${S}/XEphem
+
+ dodoc Copyright README INSTALL
+ mv ${S}/GUI/xephem/xephem.man ${S}/xephem.1
+ doman ${S}/xephem.1
+}