summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-29 18:27:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-29 18:27:36 +0000
commit2cec73e941ba418837b03f8186910905a0d1a6b0 (patch)
treedead5c265ea7548d4b695667107afc87cf057cb9 /sci-astronomy
parentRequire php built with reflection use-flag (diff)
downloadgentoo-2-2cec73e941ba418837b03f8186910905a0d1a6b0.tar.gz
gentoo-2-2cec73e941ba418837b03f8186910905a0d1a6b0.tar.bz2
gentoo-2-2cec73e941ba418837b03f8186910905a0d1a6b0.zip
Now included proper makefile patches
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/funtools/ChangeLog9
-rw-r--r--sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch305
-rw-r--r--sci-astronomy/funtools/funtools-1.4.4-r1.ebuild (renamed from sci-astronomy/funtools/funtools-1.4.4.ebuild)3
3 files changed, 315 insertions, 2 deletions
diff --git a/sci-astronomy/funtools/ChangeLog b/sci-astronomy/funtools/ChangeLog
index af2f56ff57fd..ad05586d2c42 100644
--- a/sci-astronomy/funtools/ChangeLog
+++ b/sci-astronomy/funtools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-astronomy/funtools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/ChangeLog,v 1.5 2010/01/29 02:15:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/ChangeLog,v 1.6 2010/01/29 18:27:33 bicatali Exp $
+
+*funtools-1.4.4-r1 (29 Jan 2010)
+
+ 29 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -funtools-1.4.4.ebuild, +funtools-1.4.4-r1.ebuild,
+ +files/funtools-1.4.4-makefiles.patch:
+ Now included proper makefile patches
*funtools-1.4.4 (29 Jan 2010)
diff --git a/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch b/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch
new file mode 100644
index 000000000000..6253752945cd
--- /dev/null
+++ b/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch
@@ -0,0 +1,305 @@
+diff -Nur funtools-1.4.4.orig/filter/Makefile.in funtools-1.4.4/filter/Makefile.in
+--- funtools-1.4.4.orig/filter/Makefile.in 2010-01-29 18:19:54.000000000 +0000
++++ funtools-1.4.4/filter/Makefile.in 2010-01-29 18:20:07.000000000 +0000
+@@ -29,6 +29,9 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++includedir = @includedir@
++libdir = @libdir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -38,13 +41,13 @@
+ INSTALL_ROOT =
+
+ # Directory in which to install the .a, .so, and .o files:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the programs:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the include files:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/filter
+
+ # util files are in the util directory at same level
+ UTIL_INC = -I../util
+@@ -55,7 +58,7 @@
+ #FITSY_LIBS = -L../fitsy
+
+ # wcs files are in the wcs subdirectory
+-WCS_INC = -I../wcs
++WCS_INC = -I/usr/include/wcs
+ #WCS_LIBS = -L../wcs -lwcs
+
+ # extra includes for compiling
+@@ -161,7 +164,7 @@
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -230,6 +233,10 @@
+ $(RM) swap_c.h
+ ./inc.sed SWAP_C < swap.c > swap_c.h
+
++swap_c.h: swap.c inc.sed
++ $(RM) swap_c.h
++ ./inc.sed SWAP_C < swap.c > swap_c.h
++
+ events_c.h: evfilter.c inc.sed
+ $(RM) events_c.h
+ ./inc.sed EVENTS_C < evfilter.c > events_c.h
+diff -Nur funtools-1.4.4.orig/fitsy/Makefile.in funtools-1.4.4/fitsy/Makefile.in
+--- funtools-1.4.4.orig/fitsy/Makefile.in 2010-01-29 18:19:54.000000000 +0000
++++ funtools-1.4.4/fitsy/Makefile.in 2010-01-29 18:20:07.000000000 +0000
+@@ -28,6 +28,11 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++includedir = @includedir@
++mandir = @mandir@
++datadir = @datadir@
++libdir = @libdir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -37,13 +42,13 @@
+ INSTALL_ROOT =
+
+ # Directory in which to install the .a, .so, and .o files:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the programs:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the include files:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/fitsy
+
+ # There are just too many different versions of "install" around;
+ # better to use the install-sh script that comes with the distribution,
+@@ -187,7 +192,7 @@
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+diff -Nur funtools-1.4.4.orig/gnu/Makefile.in funtools-1.4.4/gnu/Makefile.in
+--- funtools-1.4.4.orig/gnu/Makefile.in 2010-01-29 18:19:54.000000000 +0000
++++ funtools-1.4.4/gnu/Makefile.in 2010-01-29 18:20:07.000000000 +0000
+@@ -21,6 +21,11 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++includedir = @includedir@
++mandir = @mandir@
++datadir = @datadir@
++libdir = @libdir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -53,13 +58,13 @@
+ EXTRA_OBJS = @EXTRA_OBJS@
+
+ # Directory in which to install the .a, .so, and .o files:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the programs:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the include files:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
+
+ # There are just too many different versions of "install" around;
+ # better to use the install-sh script that comes with the distribution,
+diff -Nur funtools-1.4.4.orig/Makefile.in funtools-1.4.4/Makefile.in
+--- funtools-1.4.4.orig/Makefile.in 2010-01-29 18:19:54.000000000 +0000
++++ funtools-1.4.4/Makefile.in 2010-01-29 18:20:07.000000000 +0000
+@@ -28,6 +28,11 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++includedir = @includedir@
++mandir = @mandir@
++datadir = @datadir@
++libdir = @libdir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -37,19 +42,19 @@
+ INSTALL_ROOT =
+
+ # Directory in which to install the .a or .so binary for the FUNTOOLS library:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the program wish:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the funtools.h include file:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools
+
+ # Top-level directory for manual entries:
+-MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
++MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)
+
+ # Top-level directory for share entries:
+-MAN_SHARE_DIR = $(INSTALL_ROOT)$(prefix)/share/funtools
++MAN_SHARE_DIR = $(INSTALL_ROOT)$(datadir)/funtools
+
+ # util files are in the util subdirectory
+ UTIL_INC = -I./util
+@@ -60,7 +65,7 @@
+ # FITSY_LIBS = -L./fitsy -lfitsy
+
+ # wcs files are in the wcs subdirectory
+-WCS_INC = -I./wcs
++WCS_INC = -I/usr/include/wcs
+ # WCS_LIBS = -L./wcs -lwcs
+
+ # filter files are in the filter subdirectory
+@@ -225,7 +230,7 @@
+ echo $(PROGS) | ./mkfunmainlib > funmainlib.c;
+
+ shlib: sublib $(LIBOBJS)
+- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
++ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
+ (cd $(PACKAGE)tmp && ar x ../$(LIB)); \
+ CC='$(CC)' CXX=$(CXX) \
+ ./mklib -o $(PACKAGE) $(PACKAGE)tmp/*.o; \
+@@ -237,7 +242,7 @@
+ $(RANLIB) lib$(PACKAGE)MainLib.a)
+
+ shmainlib: mainlib
+- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
++ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
+ (cd $(PACKAGE)tmp && ar x ../lib$(PACKAGE)MainLib.a); \
+ CC='$(CC)' CXX='$(CXX)' \
+ ./mklib -o $(PACKAGE)MainLib -L. -lfuntools $(PACKAGE)tmp/*.o;\
+@@ -248,7 +253,7 @@
+ $(RANLIB) libtclfun.a)
+
+ shtclfun: tclfun
+- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
++ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
+ (cd $(PACKAGE)tmp && ar x ../$(LIB) && ar x ../libtclfun.a); \
+ CC='$(CC)' CXX='$(CXX)' \
+ ./mklib -o tclfun $(PACKAGE)tmp/*.o; \
+@@ -422,7 +427,7 @@
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -462,7 +467,7 @@
+ install-man:
+ @if [ ! -d $(MAN_INSTALL_DIR) ] ; then \
+ echo "Making directory $(MAN_INSTALL_DIR)"; \
+- mkdir $(MAN_INSTALL_DIR); \
++ mkdir -p $(MAN_INSTALL_DIR); \
+ chmod 755 $(MAN_INSTALL_DIR); \
+ else true; \
+ fi;
+@@ -473,7 +478,7 @@
+ M="$(MAN_INSTALL_DIR)/man$$E"; \
+ if [ ! -d $$M ] ; then \
+ echo "Making directory $$M"; \
+- mkdir $$M; \
++ mkdir -p $$M; \
+ chmod 755 $$M; \
+ else true; \
+ fi; \
+diff -Nur funtools-1.4.4.orig/util/Makefile.in funtools-1.4.4/util/Makefile.in
+--- funtools-1.4.4.orig/util/Makefile.in 2010-01-29 18:19:54.000000000 +0000
++++ funtools-1.4.4/util/Makefile.in 2010-01-29 18:20:07.000000000 +0000
+@@ -29,6 +29,11 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++includedir = @includedir@
++mandir = @mandir@
++datadir = @datadir@
++libdir = @libdir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -38,13 +43,13 @@
+ INSTALL_ROOT =
+
+ # Directory in which to install the .a, .so, and .o files:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the programs:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the include files:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/util
+
+ # extra includes for compiling
+ INCLUDES =
+@@ -200,12 +205,24 @@
+ tlaunch2: tlaunch2.o
+ $(CC) $(LDFLAGS) tlaunch2.o -o tlaunch2
+
++tlaunch.o: tlaunch.c
++
++tlaunch: tlaunch.o launch.o $(LIB)
++ $(CC) $(LDFLAGS) tlaunch.o launch.o -o tlaunch $(LIB) $(LIBS) \
++ $(EXTRA_LIBS)
++
++tlaunch2.o: tlaunch2.c
++
++tlaunch2: tlaunch2.o
++ $(CC) $(LDFLAGS) tlaunch2.o -o tlaunch2
++
++
+ install-binaries: $(LIB) $(PROGS)
+ @for i in $(LIB_INSTALL_DIR) $(INCLUDE_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -272,4 +289,11 @@
+ purift $(CC) $(LDFLAGS) tlaunch.o xlaunch.o -o tlaunch \
+ $(LIB) $(LIBS) $(EXTRA_LIBS)
+
++pure: tlaunch.pure
++
++tlaunch.pure: tlaunch.o launch.o $(LIB)
++ purift $(CC) $(LDFLAGS) tlaunch.o launch.o -o tlaunch \
++ $(LIB) $(LIBS) $(EXTRA_LIBS)
++
++
+ # DO NOT DELETE THIS LINE -- make depend depends on it.
diff --git a/sci-astronomy/funtools/funtools-1.4.4.ebuild b/sci-astronomy/funtools/funtools-1.4.4-r1.ebuild
index b11114caadbb..aacd9a0f510f 100644
--- a/sci-astronomy/funtools/funtools-1.4.4.ebuild
+++ b/sci-astronomy/funtools/funtools-1.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/funtools-1.4.4.ebuild,v 1.1 2010/01/29 02:15:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/funtools/funtools-1.4.4-r1.ebuild,v 1.1 2010/01/29 18:27:33 bicatali Exp $
EAPI=2
inherit eutils
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefiles.patch
sed -i \
-e "s:\${LINK}:\${LINK} ${LDFLAGS}:" \
mklib || die "sed for ldflags failed"