summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-12 06:27:48 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-12 06:27:48 +0000
commit1e532b8bb1b219a763a5a0a8569fca3656f56dde (patch)
treebc333854f56b81e81c4f9c1e77a56d13dba8671b /sci-biology/cd-hit
parentBump to 20110511, remove old (diff)
downloadgentoo-2-1e532b8bb1b219a763a5a0a8569fca3656f56dde.tar.gz
gentoo-2-1e532b8bb1b219a763a5a0a8569fca3656f56dde.tar.bz2
gentoo-2-1e532b8bb1b219a763a5a0a8569fca3656f56dde.zip
Version Bump, thanks for the notification by Martin Mokrejs
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/cd-hit')
-rw-r--r--sci-biology/cd-hit/ChangeLog8
-rw-r--r--sci-biology/cd-hit/cd-hit-4.5.1.ebuild14
-rw-r--r--sci-biology/cd-hit/cd-hit-4.5.4.ebuild43
-rw-r--r--sci-biology/cd-hit/files/4.5.4-gentoo.patch98
4 files changed, 154 insertions, 9 deletions
diff --git a/sci-biology/cd-hit/ChangeLog b/sci-biology/cd-hit/ChangeLog
index 4d17282cd697..683abd5b6493 100644
--- a/sci-biology/cd-hit/ChangeLog
+++ b/sci-biology/cd-hit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/cd-hit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/ChangeLog,v 1.1 2011/02/01 09:06:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/ChangeLog,v 1.2 2011/05/12 06:27:48 jlec Exp $
+
+*cd-hit-4.5.4 (12 May 2011)
+
+ 12 May 2011; Justin Lecher <jlec@gentoo.org> +files/4.5.4-gentoo.patch,
+ cd-hit-4.5.1.ebuild, +cd-hit-4.5.4.ebuild:
+ Version Bump, thanks for the notification by Martin Mokrejs
*cd-hit-4.5.1 (01 Feb 2011)
diff --git a/sci-biology/cd-hit/cd-hit-4.5.1.ebuild b/sci-biology/cd-hit/cd-hit-4.5.1.ebuild
index 16119f159316..c9e839eeab3c 100644
--- a/sci-biology/cd-hit/cd-hit-4.5.1.ebuild
+++ b/sci-biology/cd-hit/cd-hit-4.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/cd-hit-4.5.1.ebuild,v 1.1 2011/02/01 09:06:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/cd-hit-4.5.1.ebuild,v 1.2 2011/05/12 06:27:48 jlec Exp $
-EAPI="3"
+EAPI=3
inherit flag-o-matic toolchain-funcs
@@ -10,7 +10,7 @@ RELDATE="2011-01-31"
RELEASE="${PN}-v${PV}-${RELDATE}"
DESCRIPTION="Clustering Database at High Identity with Tolerance"
-HOMEPAGE="http://weizhong-lab.ucsd.edu/cd-hit"
+HOMEPAGE="http://weizhong-lab.ucsd.edu/cd-hit/"
SRC_URI="http://cdhit.googlecode.com/files/${RELEASE}.tgz"
SLOT="0"
@@ -31,11 +31,9 @@ src_prepare() {
}
src_compile() {
- if use openmp; then
- emake openmp=yes || die
- else
- emake || die
- fi
+ local myconf=
+ use openmp && myconf="openmp=yes"
+ emake ${myconf} || die
}
src_install() {
diff --git a/sci-biology/cd-hit/cd-hit-4.5.4.ebuild b/sci-biology/cd-hit/cd-hit-4.5.4.ebuild
new file mode 100644
index 000000000000..c4760b447462
--- /dev/null
+++ b/sci-biology/cd-hit/cd-hit-4.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cd-hit/cd-hit-4.5.4.ebuild,v 1.1 2011/05/12 06:27:48 jlec Exp $
+
+EAPI=4
+
+inherit flag-o-matic toolchain-funcs
+
+RELDATE="2011-03-07"
+RELEASE="${PN}-v${PV}-${RELDATE}"
+
+DESCRIPTION="Clustering Database at High Identity with Tolerance"
+HOMEPAGE="http://weizhong-lab.ucsd.edu/cd-hit/"
+SRC_URI="http://cdhit.googlecode.com/files/${RELEASE}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="openmp"
+
+S="${WORKDIR}"/${RELEASE}
+
+pkg_setup() {
+ use openmp && ! tc-has-openmp && die "Please switch to an openmp compatible compiler"
+}
+
+src_prepare() {
+ tc-export CXX
+ use openmp || append-flags -DNO_OPENMP
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ local myconf=
+ use openmp && myconf="openmp=yes"
+ emake ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${ED}/usr/bin" install
+ dodoc ChangeLog cdhit-user-guide.pdf
+}
diff --git a/sci-biology/cd-hit/files/4.5.4-gentoo.patch b/sci-biology/cd-hit/files/4.5.4-gentoo.patch
new file mode 100644
index 000000000000..5aa9b79e02ae
--- /dev/null
+++ b/sci-biology/cd-hit/files/4.5.4-gentoo.patch
@@ -0,0 +1,98 @@
+ Makefile | 36 ++++++++++++++++++------------------
+ 1 files changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e8bac1d..bd31093 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,7 @@ CCFLAGS = -O2 -DNO_OPENMP
+ # in command line:
+ # make openmp=yes
+ ifeq ($(openmp),yes)
+-CCFLAGS = -O2 -fopenmp
++CXXFLAGS += -fopenmp
+ endif
+
+ # support debugging
+@@ -18,16 +18,16 @@ endif
+ # make debug=yes
+ # make openmp=yes debug=yes
+ ifeq ($(debug),yes)
+-CCFLAGS += -ggdb
++CXXFLAGS += -ggdb
+ endif
+
+ #LDFLAGS = -static -o
+-LDFLAGS = -o
++LDFLAGS += -o
+
+ PROGS = cd-hit cd-hit-est cd-hit-2d cd-hit-est-2d cd-hit-div cd-hit-454
+
+ .c++.o:
+- $(CC) $(CCFLAGS) -c $<
++ $(CXX) $(CXXFLAGS) -c $<
+
+ all: $(PROGS)
+
+@@ -37,47 +37,47 @@ clean:
+ # programs
+
+ cd-hit: cdhit-common.o cdhit-utility.o cdhit.o
+- $(CC) $(CCFLAGS) cdhit.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit
++ $(CXX) $(CXXFLAGS) cdhit.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit
+
+ cd-hit-2d: cdhit-common.o cdhit-utility.o cdhit-2d.o
+- $(CC) $(CCFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-2d
++ $(CXX) $(CXXFLAGS) cdhit-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-2d
+
+ cd-hit-est: cdhit-common.o cdhit-utility.o cdhit-est.o
+- $(CC) $(CCFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est
++ $(CXX) $(CXXFLAGS) cdhit-est.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est
+
+ cd-hit-est-2d: cdhit-common.o cdhit-utility.o cdhit-est-2d.o
+- $(CC) $(CCFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est-2d
++ $(CXX) $(CXXFLAGS) cdhit-est-2d.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-est-2d
+
+ cd-hit-div: cdhit-common.o cdhit-utility.o cdhit-div.o
+- $(CC) $(CCFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-div
++ $(CXX) $(CXXFLAGS) cdhit-div.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-div
+
+ cd-hit-454: cdhit-common.o cdhit-utility.o cdhit-454.o
+- $(CC) $(CCFLAGS) cdhit-454.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-454
++ $(CXX) $(CXXFLAGS) cdhit-454.o cdhit-common.o cdhit-utility.o $(LDFLAGS) cd-hit-454
+
+ # objects
+ cdhit-common.o: cdhit-common.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-common.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-common.c++ -c
+
+ cdhit-utility.o: cdhit-utility.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-utility.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-utility.c++ -c
+
+ cdhit.o: cdhit.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit.c++ -c
+
+ cdhit-2d.o: cdhit-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-2d.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-2d.c++ -c
+
+ cdhit-est.o: cdhit-est.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-est.c++ -c
+
+ cdhit-est-2d.o: cdhit-est-2d.c++ cdhit-utility.h
+- $(CC) $(CCFLAGS) cdhit-est-2d.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-est-2d.c++ -c
+
+ cdhit-div.o: cdhit-div.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-div.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-div.c++ -c
+
+ cdhit-454.o: cdhit-454.c++ cdhit-common.h
+- $(CC) $(CCFLAGS) cdhit-454.c++ -c
++ $(CXX) $(CXXFLAGS) cdhit-454.c++ -c
+
+ PREFIX ?= /usr/local/bin
+