summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2008-08-26 18:51:27 +0000
committerOlivier Fisette <ribosome@gentoo.org>2008-08-26 18:51:27 +0000
commit64c957aa7a7609a4a4e3456dc38c2ef978e50a80 (patch)
tree398472bb8f3a7804fd280f34cdd41f33ee30dd71 /sci-biology/emboss
parentMake blockers on e2fsprogs-libs mutual. Fixes bug #234907 (diff)
downloadgentoo-2-64c957aa7a7609a4a4e3456dc38c2ef978e50a80.tar.gz
gentoo-2-64c957aa7a7609a4a4e3456dc38c2ef978e50a80.tar.bz2
gentoo-2-64c957aa7a7609a4a4e3456dc38c2ef978e50a80.zip
New upstream version.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog7
-rw-r--r--sci-biology/emboss/emboss-6.0.1.ebuild104
2 files changed, 110 insertions, 1 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 1de7d18f5144..f352634a7764 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/emboss
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.46 2008/01/25 23:51:41 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.47 2008/08/26 18:51:27 ribosome Exp $
+
+*emboss-6.0.1 (26 Aug 2008)
+
+ 26 Aug 2008; Olivier Fisette <ribosome@gentoo.org> +emboss-6.0.1.ebuild:
+ New upstream version.
25 Jan 2008; Markus Dittrich <markusle@gentoo.org>
+files/emboss-5.0.0-as-needed.patch, emboss-4.0.0.ebuild,
diff --git a/sci-biology/emboss/emboss-6.0.1.ebuild b/sci-biology/emboss/emboss-6.0.1.ebuild
new file mode 100644
index 000000000000..2e4169213d31
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.0.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.0.1.ebuild,v 1.1 2008/08/26 18:51:27 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X png minimal"
+
+DEPEND="X? ( x11-libs/libXt )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )"
+
+PDEPEND="!minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ >=sci-biology/rebase-707
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-5.0.0-as-needed.patch
+
+ local link_string="-lX11";
+ if use png; then
+ link_string="${link_string} -lgd -lpng"
+ fi
+ sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
+ || die "Failed to patch ajax Makefile"
+}
+
+src_compile() {
+ EXTRA_CONF="--includedir=${D}/usr/include/emboss"
+ ! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
+ ! use png && EXTRA_CONF="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${EXTRA_CONF} || die
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will eventually be available as a separate package.
+ sed -i -e "s/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/" \
+ Makefile || die
+ emake || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS \
+ || die "Failed to install documentation."
+ newdoc "${FILESDIR}"/${PN}-README.Gentoo-1 README.Gentoo \
+ || die "Failed to install Gentoo readme file."
+
+ # Install env file for setting libplplot and acd files path.
+ cat <<- EOF > 22emboss
+ # plplot libs dir
+ PLPLOT_LIB="/usr/share/EMBOSS/"
+ # ACD files location
+ EMBOSS_ACDROOT="/usr/share/EMBOSS/acd"
+ EOF
+ doenvd 22emboss || die "Failed to install environment file."
+
+ # Symlink preinstalled docs to "/usr/share/doc".
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
+
+ # Remove useless dummy files from the image.
+ rm "${D}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
+ || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${D}"/usr/share/EMBOSS/data/CODONS \
+ "${D}"/usr/share/EMBOSS/data/CODONS.orig || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This avoids file collisions with versions of rebase that install their
+ # own enzyme prototypes file (see bug #118832).
+ mv "${D}"/usr/share/EMBOSS/data/embossre.equ \
+ "${D}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ die "Failed to move enzyme equivalence file."
+}