summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-09 16:29:05 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-09 16:29:05 +0000
commit9556bf614fbf8b86e2adacb24f404e6855f89a63 (patch)
tree73ed723cda7d28de748189c1313b323d3352ed8b /sci-biology/emboss
parentx86 stable per bug 353573 (diff)
downloadgentoo-2-9556bf614fbf8b86e2adacb24f404e6855f89a63.tar.gz
gentoo-2-9556bf614fbf8b86e2adacb24f404e6855f89a63.tar.bz2
gentoo-2-9556bf614fbf8b86e2adacb24f404e6855f89a63.zip
EAPI=4 takes three arguments on use_with
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog5
-rw-r--r--sci-biology/emboss/emboss-6.3.1_p4.ebuild28
2 files changed, 12 insertions, 21 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 8bbed2e361c4..5d6f872e7e7c 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/emboss
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.60 2011/03/09 13:09:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.61 2011/03/09 16:29:05 jlec Exp $
+
+ 09 Mar 2011; Justin Lecher <jlec@gentoo.org> emboss-6.3.1_p4.ebuild:
+ EAPI=4 takes three arguments on use_with
*emboss-6.3.1_p4 (09 Mar 2011)
diff --git a/sci-biology/emboss/emboss-6.3.1_p4.ebuild b/sci-biology/emboss/emboss-6.3.1_p4.ebuild
index 40cd20b4ed8e..e235c73d5259 100644
--- a/sci-biology/emboss/emboss-6.3.1_p4.ebuild
+++ b/sci-biology/emboss/emboss-6.3.1_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.3.1_p4.ebuild,v 1.1 2011/03/09 13:09:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.3.1_p4.ebuild,v 1.2 2011/03/09 16:29:05 jlec Exp $
EAPI="4"
@@ -58,32 +58,20 @@ src_prepare() {
eautoreconf
}
-conf-with() {
- # USE with-option Option
- if use ${1}; then
- echo "--with-${2}=${3}"
- else
- echo "--without-${2}"
- fi
-}
-
src_configure() {
- local myconf
- myconf="--includedir=${ED}/usr/include/emboss --enable-systemlibs"
-
- myconf="${myconf} $(conf-with png pngdriver ${EPREFIX}/usr)"
- myconf="${myconf} $(conf-with doc docroot ${EPREFIX}/usr)"
- myconf="${myconf} $(conf-with pdf hpdf ${EPREFIX}/usr)"
- myconf="${myconf} $(conf-with mysql mysql ${EPREFIX}/usr/bin/mysql_config)"
- myconf="${myconf} $(conf-with postgresql postgresql ${EPREFIX}/usr/bin/pg_config)"
-
econf \
$(use_with X x) \
+ $(use_with png pngdriver "${EPREFIX}/usr") \
+ $(use_with doc docroot "${EPREFIX}/usr") \
+ $(use_with pdf hpdf "${EPREFIX}/usr") \
+ $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config") \
+ $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config") \
$(use_enable amd64 64) \
$(use_enable largefile large) \
$(use_enable static-libs static) \
--without-java \
- ${myconf}
+ --enable-systemlibs \
+ --includedir="${ED}/usr/include/emboss"
}
src_install() {