summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:03:45 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:03:45 +0000
commitb2ae43272b4d7ff54846121c493f62aeda4976c0 (patch)
tree300374c8bd9f29c862fcf3241c8e3f7f50cb48b5 /sci-biology/mammoth
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-b2ae43272b4d7ff54846121c493f62aeda4976c0.tar.gz
gentoo-2-b2ae43272b4d7ff54846121c493f62aeda4976c0.tar.bz2
gentoo-2-b2ae43272b4d7ff54846121c493f62aeda4976c0.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/mammoth')
-rw-r--r--sci-biology/mammoth/ChangeLog5
-rw-r--r--sci-biology/mammoth/mammoth-1.0.ebuild18
2 files changed, 10 insertions, 13 deletions
diff --git a/sci-biology/mammoth/ChangeLog b/sci-biology/mammoth/ChangeLog
index c9390bd178d2..fe47461e2349 100644
--- a/sci-biology/mammoth/ChangeLog
+++ b/sci-biology/mammoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/mammoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mammoth/ChangeLog,v 1.2 2010/09/13 12:43:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mammoth/ChangeLog,v 1.3 2010/12/16 15:03:45 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> mammoth-1.0.ebuild:
+ Removal of fortran.eclass, #348851
13 Sep 2010; Markos Chandras <hwoarang@gentoo.org> mammoth-1.0.ebuild:
Keyworded for amd64. Bug #335605
diff --git a/sci-biology/mammoth/mammoth-1.0.ebuild b/sci-biology/mammoth/mammoth-1.0.ebuild
index 8757a105b140..4c78b88f2e91 100644
--- a/sci-biology/mammoth/mammoth-1.0.ebuild
+++ b/sci-biology/mammoth/mammoth-1.0.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mammoth/mammoth-1.0.ebuild,v 1.2 2010/09/13 12:43:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mammoth/mammoth-1.0.ebuild,v 1.3 2010/12/16 15:03:45 jlec Exp $
-inherit autotools eutils fortran
+inherit autotools eutils flag-o-matic toolchain-funcs
MY_P="${P}-src"
DESCRIPTION="MAtching Molecular Models Obtained from THeory"
HOMEPAGE="http://ub.cbm.uam.es/software.php"
SRC_URI="${MY_P}.tgz"
+
LICENSE="mammoth"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+
RESTRICT="fetch"
-RDEPEND=""
-DEPEND="${RDEPEND}"
+
S=${WORKDIR}/${MY_P}
-FORTRAN="gfortran g77"
pkg_nofetch() {
einfo "Download the source code for MAMMOTH from"
@@ -32,7 +32,7 @@ src_unpack() {
# Broken with gfortran without this patch
epatch "${FILESDIR}"/${PV}-consistent-system-intrinsic.patch
- case ${FORTRANC} in
+ case $(tc-getFC) in
g77) append-fflags -ffixed-line-length-none ;;
gfortran) append-fflags -ffixed-line-length-none ;;
esac
@@ -47,9 +47,3 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README AUTHORS || die
}
-
-append-fflags() {
- [[ -z $* ]] && return 0
- export FFLAGS="${FFLAGS} $*"
- return 0
-}