summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-17 06:49:59 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-17 06:49:59 +0000
commit7f539a36c47dc3e14945c8560a621cbec3dc550f (patch)
tree1ad190b6df4a2e03859109f10c4169be669222f7 /sci-biology/mrbayes
parentDrop old; bump EAPI (diff)
downloadgentoo-2-7f539a36c47dc3e14945c8560a621cbec3dc550f.tar.gz
gentoo-2-7f539a36c47dc3e14945c8560a621cbec3dc550f.tar.bz2
gentoo-2-7f539a36c47dc3e14945c8560a621cbec3dc550f.zip
Import changes from science overlay
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/mrbayes')
-rw-r--r--sci-biology/mrbayes/ChangeLog11
-rw-r--r--sci-biology/mrbayes/metadata.xml4
-rw-r--r--sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild6
-rw-r--r--sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild62
4 files changed, 75 insertions, 8 deletions
diff --git a/sci-biology/mrbayes/ChangeLog b/sci-biology/mrbayes/ChangeLog
index 6e131881219e..38863e55c8f8 100644
--- a/sci-biology/mrbayes/ChangeLog
+++ b/sci-biology/mrbayes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/mrbayes
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/ChangeLog,v 1.26 2011/12/21 09:05:28 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/ChangeLog,v 1.27 2015/04/17 06:49:59 jlec Exp $
+
+*mrbayes-3.1.2-r2 (17 Apr 2015)
+
+ 17 Apr 2015; Justin Lecher <jlec@gentoo.org> +mrbayes-3.1.2-r2.ebuild,
+ metadata.xml, mrbayes-3.1.2-r1.ebuild:
+ Import changes from science overlay
21 Dec 2011; Justin Lecher <jlec@gentoo.org> -mrbayes-3.1.2.ebuild:
Cleaned old
@@ -96,4 +102,3 @@
19 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> :
Initial commit
-
diff --git a/sci-biology/mrbayes/metadata.xml b/sci-biology/mrbayes/metadata.xml
index d33282dbbb50..9b0503f3a779 100644
--- a/sci-biology/mrbayes/metadata.xml
+++ b/sci-biology/mrbayes/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-biology</herd>
-<longdescription>
+ <herd>sci-biology</herd>
+ <longdescription>
MrBayes is a program for the Bayesian estimation of phylogeny.
Bayesian inference of phylogeny is based upon a quantity called the
posterior probability distribution of trees, which is the probability of a
diff --git a/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild b/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild
index 69b7d11509bf..1e74c5fb27f8 100644
--- a/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild
+++ b/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild,v 1.5 2011/12/21 08:59:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/mrbayes-3.1.2-r1.ebuild,v 1.6 2015/04/17 06:49:59 jlec Exp $
EAPI=4
@@ -18,7 +18,7 @@ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
DEPEND="
sys-libs/ncurses
mpi? ( virtual/mpi )
- readline? ( sys-libs/readline )"
+ readline? ( sys-libs/readline:0 )"
RDEPEND="${DEPEND}"
src_prepare() {
diff --git a/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild b/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..c60f61a93433
--- /dev/null
+++ b/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/mrbayes-3.1.2-r2.ebuild,v 1.1 2015/04/17 06:49:59 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="http://mrbayes.csit.fsu.edu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="debug mpi readline"
+
+DEPEND="
+ sys-libs/ncurses
+ mpi? ( virtual/mpi )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use mpi; then
+ sed -e "s:MPI ?= no:MPI=yes:" -i Makefile || die "Patching MPI support."
+ fi
+ if ! use readline; then
+ sed -e "s:USEREADLINE ?= yes:USEREADLINE=no:" \
+ -i Makefile || die "Patching readline support."
+ else
+ # Only needed for OSX with an old (4.x) version of
+ # libreadline, but it doesn't hurt for other distributions.
+ epatch "${FILESDIR}"/mb_readline_312.patch
+ fi
+ sed -e 's:-ggdb::g' -i Makefile || die
+}
+
+src_compile() {
+ local myconf mycc
+
+ if use mpi; then
+ mycc=mpicc
+ else
+ mycc=$(tc-getCC)
+ fi
+
+ use mpi && myconf="MPI=yes"
+ use readline || myconf="${myconf} USEREADLINE=no"
+ use debug && myconf="${myconf} DEBUG=yes"
+ emake \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=${mycc} \
+ ${myconf}
+}
+
+src_install() {
+ dobin mb
+ insinto /usr/share/${PN}
+ doins *.nex
+}