summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-03-08 00:11:55 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-03-08 00:11:55 +0000
commit34c326df918abbcd66471c67c8a8e84d8961aa6b (patch)
treec7624c41f1177511cf63215fdf101b689a6f05cf /sci-biology/seaview/seaview-20060213.ebuild
parentVersion bump. (diff)
downloadgentoo-2-34c326df918abbcd66471c67c8a8e84d8961aa6b.tar.gz
gentoo-2-34c326df918abbcd66471c67c8a8e84d8961aa6b.tar.bz2
gentoo-2-34c326df918abbcd66471c67c8a8e84d8961aa6b.zip
Bump to most recent modification date on upstream's unversioned tarball. Fixes problem with file-open dialog not finding files, among others.
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'sci-biology/seaview/seaview-20060213.ebuild')
-rw-r--r--sci-biology/seaview/seaview-20060213.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/seaview/seaview-20060213.ebuild b/sci-biology/seaview/seaview-20060213.ebuild
new file mode 100644
index 000000000000..2d9708b03041
--- /dev/null
+++ b/sci-biology/seaview/seaview-20060213.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-20060213.ebuild,v 1.1 2006/03/08 00:11:54 spyderous Exp $
+
+DESCRIPTION="A graphical multiple sequence alignment editor"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="x11-libs/fltk
+ =media-libs/pdflib-6.0*
+ sci-biology/clustalw"
+
+src_compile() {
+ # Corrects location of libfltk.
+ CFLAGS="${CFLAGS} -c -I/usr/include/fltk-1.1"
+ sed -i -e "s%\"seaview.help\", %\"/usr/share/${PN}/seaview.help\", %" seaview.cxx || die
+ sed -i -e 's:-L$(FLTK)/lib:-L/usr/lib/fltk-1.1:' Makefile || die
+
+ emake -e || die
+}
+
+src_install() {
+ dobin seaview seaview_align.sh
+ insinto /usr/share/${PN}
+ doins protein.mase seaview.help
+}