summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-12-07 05:53:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-12-07 05:53:06 +0000
commit32c67cc73f64c2ddb63bfb6ea4efcac4caf41ba5 (patch)
treec40e558f7c41947c2a1caf5d6738c6ec3c0af390 /sci-biology/t-coffee
parentprune some unused versions and files (diff)
downloadgentoo-2-32c67cc73f64c2ddb63bfb6ea4efcac4caf41ba5.tar.gz
gentoo-2-32c67cc73f64c2ddb63bfb6ea4efcac4caf41ba5.tar.bz2
gentoo-2-32c67cc73f64c2ddb63bfb6ea4efcac4caf41ba5.zip
Latest version - thanks to Martin Mokrejs on bug #201495
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog7
-rw-r--r--sci-biology/t-coffee/files/digest-t-coffee-5.313
-rw-r--r--sci-biology/t-coffee/t-coffee-5.31.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index 83ed2b9f93ae..2fa04cf550a0 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.23 2007/07/02 15:24:09 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.24 2007/12/07 05:53:05 je_fro Exp $
+
+*t-coffee-5.31 (07 Dec 2007)
+
+ 07 Dec 2007; Jeff Gardner <je_fro@gentoo.org> +t-coffee-5.31.ebuild:
+ Latest version - thanks to Martin Mokrejs on bug #201495
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> t-coffee-4.96.ebuild,
t-coffee-5.05.ebuild:
diff --git a/sci-biology/t-coffee/files/digest-t-coffee-5.31 b/sci-biology/t-coffee/files/digest-t-coffee-5.31
new file mode 100644
index 000000000000..e226a14a4f80
--- /dev/null
+++ b/sci-biology/t-coffee/files/digest-t-coffee-5.31
@@ -0,0 +1,3 @@
+MD5 3c5eea83be2c18f45b55a9afac643b25 T-COFFEE_distribution_Version_5.31.tar.gz 2857478
+RMD160 95cb261c57fe31b3c26bdac85c10a4609692c2eb T-COFFEE_distribution_Version_5.31.tar.gz 2857478
+SHA256 43a38a6e9d0dc4bd663704b69c94c3aefd15608e5113703fad8d42f8fdc1a615 T-COFFEE_distribution_Version_5.31.tar.gz 2857478
diff --git a/sci-biology/t-coffee/t-coffee-5.31.ebuild b/sci-biology/t-coffee/t-coffee-5.31.ebuild
new file mode 100644
index 000000000000..52c33eaff805
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-5.31.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-5.31.ebuild,v 1.1 2007/12/07 05:53:05 je_fro Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="t-coffee"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+RESTRICT="mirror"
+
+DEPEND="sci-biology/clustalw"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC) ${CFLAGS}/" -i makefile || die \
+ "Failed to patch makefile."
+}
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ make all || die_compile
+}
+
+src_install() {
+ dobin "${TCDIR}"/bin/t_coffee \
+ || die "Failed to install program."
+
+ insinto /usr/share/${PN}/lib/html
+ doins "${TCDIR}"/html/* \
+ || die "Failed to install Web interface files."
+
+ cd "${TCDIR}"/doc
+ dodoc aln_compare.doc.txt README4T-COFFEE seq_reformat.doc.txt \
+ t_coffee_technical.txt t_coffee_tutorial.txt \
+ || die "Failed to install text documentation."
+
+ dohtml t_coffee_technical.htm t_coffee_tutorial.htm \
+ || die "Failed to install HTML documentation."
+
+ insinto /usr/share/doc/${PF}
+ doins t_coffee_technical.doc t_coffee_tutorial.doc \
+ || die "Failed to install DOC documentation."
+
+ insinto /usr/share/${PN}/example
+ doins "${TCDIR}"/example/* \
+ || die "Failed to install example files."
+}