summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2007-03-09 02:43:13 +0000
committerOlivier Fisette <ribosome@gentoo.org>2007-03-09 02:43:13 +0000
commit5da990e1ca35c5708914bc1761d10810355860c8 (patch)
treed26f26874af7f659bd7d5dc980cbf1e371cc9303 /sci-biology/t-coffee
parentdrop autotools eclass inherit as pointed out by ferringb (diff)
downloadgentoo-2-5da990e1ca35c5708914bc1761d10810355860c8.tar.gz
gentoo-2-5da990e1ca35c5708914bc1761d10810355860c8.tar.bz2
gentoo-2-5da990e1ca35c5708914bc1761d10810355860c8.zip
New upstream version.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog9
-rw-r--r--sci-biology/t-coffee/files/digest-t-coffee-4.963
-rw-r--r--sci-biology/t-coffee/t-coffee-4.96.ebuild62
3 files changed, 72 insertions, 2 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index 25f8fa411b9f..1a630c6a439d 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/t-coffee
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.16 2006/09/13 23:52:04 ribosome Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.17 2007/03/09 02:43:13 ribosome Exp $
+
+*t-coffee-4.96 (09 Mar 2007)
+
+ 09 Mar 2007; Olivier Fisette <ribosome@gentoo.org> +t-coffee-4.96.ebuild:
+ New upstream version.
*t-coffee-4.45 (13 Sep 2006)
diff --git a/sci-biology/t-coffee/files/digest-t-coffee-4.96 b/sci-biology/t-coffee/files/digest-t-coffee-4.96
new file mode 100644
index 000000000000..d6f8c17360de
--- /dev/null
+++ b/sci-biology/t-coffee/files/digest-t-coffee-4.96
@@ -0,0 +1,3 @@
+MD5 ce40b2654663b7c22c1c8427fb5e32db T-COFFEE_distribution_Version_4.96.tar.gz 2863327
+RMD160 d6a7722f1fe3b2a8b186fad49e8bc136d812b610 T-COFFEE_distribution_Version_4.96.tar.gz 2863327
+SHA256 49181acd69a5723fd5b11f579b1efe685b5289bf187985b25b40c514b0af0213 T-COFFEE_distribution_Version_4.96.tar.gz 2863327
diff --git a/sci-biology/t-coffee/t-coffee-4.96.ebuild b/sci-biology/t-coffee/t-coffee-4.96.ebuild
new file mode 100644
index 000000000000..ddc5809f988a
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-4.96.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-4.96.ebuild,v 1.1 2007/03/09 02:43:13 ribosome Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A multiple sequence alignment package"
+LICENSE="t-coffee"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~ppc ~x86"
+
+RESTRICT="nomirror"
+
+DEPEND="sci-biology/clustalw"
+
+TCDIR="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+S="${TCDIR}/t_coffee_source"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC) ${CFLAGS}/" -i makefile || die \
+ "Failed to patch makefile."
+}
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ make all || die_compile
+}
+
+src_install() {
+ dobin "${TCDIR}"/bin/t_coffee || die "Failed to install program."
+
+ insinto /usr/share/${PN}/lib/html
+ doins "${TCDIR}"/html/* || die "Failed to install Web interface files."
+
+ cd "${TCDIR}"/doc
+ dodoc aln_compare.doc.txt README4T-COFFEE seq_reformat.doc.txt \
+ t_coffee_technical.txt t_coffee_tutorial.txt || die \
+ "Failed to install text documentation."
+ dohtml t_coffee_technical.htm t_coffee_tutorial.htm || die \
+ "Failed to install HTML documentation."
+ insinto /usr/share/doc/${PF}
+ doins t_coffee.pdf t_coffee_technical.doc t_coffee_tutorial.doc || die \
+ "Failed to install DOC and PDF documentation."
+
+ insinto /usr/share/${PN}/example
+ doins "${TCDIR}"/example/* || die "Failed to install example files."
+}